Alfa Romeo Forum banner

421 - 440 of 442 Posts

·
Registered
Joined
·
1,521 Posts
Surely there’s a conflict of interest between having that exhaust and a stereo? ?
Bet it sounds epic (the exhaust). Love that colour, and the ph1 interior is a great place to be!
Thanks, yes the exhaust sounds fabulous on high revs. Re the stereo, not really, I hardly use it, it’s more for the hands free telephone ;)

I see that yours is a Proteo too? It’s a colour that has grown on me, initially I would have preferred Red but the car ticked all the other boxes so I bought it. Now love it as it’s very unusual and even better the colour hasn’t faded at all.
 

·
Registered
Joined
·
238 Posts
Thanks, yes the exhaust sounds fabulous on high revs. Re the stereo, not really, I hardly use it, it’s more for the hands free telephone ;)

I see that yours is a Proteo too? It’s a colour that has grown on me, initially I would have preferred Red but the car ticked all the other boxes so I bought it. Now love it as it’s very unusual and even better the colour hasn’t faded at all.
Yes the exhaust is the best music, I’ve got a part Ragazzon system and just love it. Not driven the car this weekend and I’ve missed it but the 156 hasn’t been out for 2 weeks.
Proteo red is my favourite, I like red but it looks so good on the 916.
 

·
Registered
Joined
·
1,368 Posts
Hi folks, just wondering if anyone knows how I could get my hands on a ph1 V6 intake flexi?
I need the cable throttle body version and yes I’ve seen the diy intake thread elsewhere, I was hoping to get an original pipe, as my rebuild is fairly factory looking. Many thanks for any pointers. Cheers Chris
 

·
Registered
Joined
·
1,810 Posts
Dismantled (read: broke slightly, then sort of fixed back together) idle control valve on CF1 2.0TS. A spot of light corrosion mixed with a good helping of carbon dust deposits = sticky rotating valve. Lots of cleaning, gentle lubrication, a new screw hole to hold it all together again, and the idle is now back to being rock solid. Roll on the time I can drive her again!
 

·
Registered
Joined
·
2,431 Posts
...
 

·
Registered
Joined
·
2,431 Posts
Oops... meant to post in ‘what have you done to your 916 today’.
 

·
Registered
Joined
·
1,368 Posts
Hi guys,
I'm from Italy and I present my GTV 3.0v6 24v phase 1.
It's one of the first GTV produced with this engine in november 1996.
I bought the car 2 months ago and it is under restoration, i also have a Giulia MY2018.
I see that the passion for Alfa Romeo is very strong also in the UK.

View attachment 935310

View attachment 935311

View attachment 935313

View attachment 935314
Ciao Francesco! Your PH1 looks great 👍🏻 I think the tax for this car will be expensive in Italy?
 

·
Registered
Joined
·
1,368 Posts
Hoping that someone can help with a perplexing issue: I have finally finished rebuilding my 1998 24v V6 GTV but have an issue with some engine bay plugs which don’t seem to match! Firstly the water temp sensor that fits in the thermostat housing doesn’t appear to have a plug from the loom that matches it and secondly, I can’t find a connector to plug the rear bank knock sensor into! (Front bank sensor is plugged in and sitting in the holder on top of the alloy engine mount). Anyone out there with a PH2 engine who can help?
936846
 

·
Registered
Joined
·
1,368 Posts
Air inlet pipes are not fitted in these pictures. The brown plug (3 pin) behind my hand plugs into the air pipe sensor I think, I am holding the rear bank knock sensor plug but does this plug into the blue plug below?
 

·
Registered
Joined
·
1,368 Posts
This is the water temp sensor that inserts into the thermostat housing - the only plug I can find close by doesn’t match the pins! Confusingly, the plug bodies fit together but the pins don’t seem to match at all.....
936847
936848
 

·
Registered
Joined
·
1,368 Posts
Hope this helps
Thanks, that at least clears up that the brown plug goes to the inlet sensor. Still confused about the thermostat housing though - in your pics, it looks like there are 2 sensors with plugs attached?
 

·
Registered
Joined
·
1,810 Posts
EDIT: just realised you're asking regarding a V6, my comment relates to a TS.

Yes, there are two sensors on Cf1 engines; one is for the ECU, the other is for the internal temperature gauge.
 
421 - 440 of 442 Posts
Top