Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
These Alfa’s have a great sense of humour.
Come out of work it’s barely 6C and the usual autumnal English day.
Pop the key wait for the glow plug light off press the brake and start her up.
Immediately the message “Excessive Radiator Fluid Temperature" pops up and then a couple of seconds later “Cruise Control switched off".

I never use the cruise as I don’t like it personally and my commute is about 8 miles fast A road and 4 or so town mileage.

So I giggled for second or two, turned her off and fired her up again, started fine both times, idles fine and no error messages in second start. Drove home just as normal no issues just as per.

Any ideas ?
Cheers Dave
 

·
Registered
Joined
·
464 Posts
Battery, dodgy earth? All electronic issues like this seem to be down to battery or earthing or both haha.

Wouldn't worry about it.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
Thanks Dan I had the same thought Re battery or maybe an Earth.
Written it down to Alfa giggles at the moment, let’s hope it doesn’t turn into a dark sense of humour 🤣

Cheers Dave


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
203 Posts
These Alfa’s have a great sense of humour.
Come out of work it’s barely 6C and the usual autumnal English day.
Pop the key wait for the glow plug light off press the brake and start her up.
Immediately the message “Excessive Radiator Fluid Temperature" pops up and then a couple of seconds later “Cruise Control switched off".

I never use the cruise as I don’t like it personally and my commute is about 8 miles fast A road and 4 or so town mileage.

So I giggled for second or two, turned her off and fired her up again, started fine both times, idles fine and no error messages in second start. Drove home just as normal no issues just as per.

Any ideas ?
Cheers Dave
I get the same errors from time to time.
More frequently on hotter weather as I've seen last summer.
Actually, it happened the day before yesterday, but I guess it was triggered because I didn't press the start button long enough.
 

·
Banned
Joined
·
3,808 Posts
These Alfa’s have a great sense of humour.
Come out of work it’s barely 6C and the usual autumnal English day.
Pop the key wait for the glow plug light off press the brake and start her up.
Immediately the message “Excessive Radiator Fluid Temperature" pops up and then a couple of seconds later “Cruise Control switched off".

I never use the cruise as I don’t like it personally and my commute is about 8 miles fast A road and 4 or so town mileage.

So I giggled for second or two, turned her off and fired her up again, started fine both times, idles fine and no error messages in second start. Drove home just as normal no issues just as per.

Any ideas ?
Cheers Dave
You have clearly not been showing her enough affection! Alfa's aren't cars, they are life forms with the kind of feelings, all of us have. Every time I get into my GT, I kiss the Steering Wheel Consequently, it has loved me back by never breaking down. Not many marriages last thirteen years!:rambo:
 

·
Registered
Joined
·
67 Posts
Discussion Starter #6
But I thought these little jokes were a sign of affectation from the lovely beast




Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
1,931 Posts
I get it. It's like when you do a silent fart under the duvet and give it a discreet wafted whilst your wife is reading a book sat next to you in bed, and wait for her reaction


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
696 Posts
LOL.....

Seriously though, :)

my last 159 and my current one both had similar issues.

in both it proved to be bad earthing/live on the battery.

Probably better it disconnect the terminals and give them a clean and re-tighten now when issues are starting to show up instead of waiting till your sat in a hospital carpark/outside work for an hour waiting for the RAC to turn up and do 2 mins work like I did (twice)

Axe
 

·
Registered
Joined
·
67 Posts
Discussion Starter #9
Axe
Was thinking similar myself sounds like head under the bonnet day tomorrow

:)

Dave


Sent from my iPad using Tapatalk
 
1 - 12 of 12 Posts
Top