Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,412 Posts
Discussion Starter #1
So ive had a nasty rattle on stary up for about 4 weeks now, yes, I know it could be the variator...........ive already had 4 in my 2001 156 Sportwagon but it only happens every now and again maybe once in every 10 start ups, not always when its cold but even when the engine is hot.

So if its not the variator it could be a loose or cracked exhaust heat shield, checked that and all seems well..........so wait for this.......decided to treat the engine to 2 full tanks of Tesco 99 unleaded..........and the rattle has disappeared.

So is this just coincidence or is it likely to have anything to do with the superunleaded?
 
A

·
Guest
Joined
·
0 Posts
Does the TS engine have a 'knock' sensor. If so then if putting higher octane fuel in cures the rattle, it suggest the knock sensor has failed in its duty...assuming it has one of course.

Thats the only logical 'take' I can offer. I suppose you have to try a tank of 'ordinary' to see if the rattle returns. Then you know you are on the right track.

We had a 1990 (pre-vw) Skoda which could supposedly run on unleaded (no cat in those days). Well it ran..but even after a mod, it still rattled like a snake (pinking..or pre-ignition). Putting leaded in changed it totally for the better. VW sorted that out with injection & electronics...and a knock sensor in later models.

Anyone else know if it has one?

AlfaLincs
 

·
Registered
Joined
·
2,412 Posts
Discussion Starter #3
Not sure about the 'knock' sensor but yes filling it up with ordinary unleaded might clarify the problem!
 

·
Registered
Joined
·
30,408 Posts
4 variators??? How many miles has your SW done? Sorry cant offer advice on the start up rattle! If it is fixed by running a higher octaine fuel it sounds like pre-ignition but it should run fine on normal 95 ron too, so who knows!
 

·
Registered
Joined
·
2,412 Posts
Discussion Starter #5
4 variators??? How many miles has your SW done? Sorry cant offer advice on the start up rattle! If it is fixed by running a higher octaine fuel it sounds like pre-ignition but it should run fine on normal 95 ron too, so who knows!
Its done 125,000 miles, the earlier varators were deemed to have a fault but the 4th one of mine i'm told has has a modification and so should be okay BUT who knows?
 

·
Registered
Joined
·
30,408 Posts
oh ok, I have just had the variator done on mine - my last 2 Alfas were V6's so never had one before!
 
1 - 6 of 6 Posts
Top