Alfa Romeo Forum banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
I'm posting this because it doesn't seem to appear on the parts CD I've got. Punched the code in and it comes up as a 164 part.

I phoned the dealer and they have said it fits all the V6's so it must be ok :D

Anyway, this is all the info on the sticky label:

Part number 7647004 "sender V6 unit"

BTW its a Bosch part!!!!

cheers, Steve :)
 
G

·
Discussion Starter · #2 ·
Thanks for the info Wrinx,
It 'll save a lot of messing around when I go down to the main dealer tomorrow to order one, as the numptys wouldn't have that part number.

Mark :)
 
G

·
Discussion Starter · #3 ·
...BTW Wrinx,what colour is the plastic on the end of the sender, where the connector fits?
The mechanic at my Alfa specialists said that they're were a couple of variations denoted by colour :confused:
 
G

·
Discussion Starter · #4 ·
It has a black rectangular female fitting with three little lugs on the outside to lock the male connector in place.

The Bosch code is:

0280130032 (just under the black plastic connector)

wrinx

ps. gonna go check it now :D
 
G

·
Discussion Starter · #6 ·
Hi Wrinx,
According to what my mechanic said, the blue one is the original factory fitted sensor, while the black one is the genuine service replacement. The Intermotor replacement is white, and (apparently) no good for the V6.

Mark wink
 
G

·
Discussion Starter · #8 ·
Hi Wrinx,
Can't really take it back as I asked for it by part no. These things are so difficult to prove that the £13 it cost may best just be seen as a lesson.
Having said that, there's also a principle involved here.

....what do you guys think?

Mark :)
 
1 - 8 of 8 Posts
Top