Alfa Romeo Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Hello,

Temp gauged hardly ever works always seems to stay at 50
the blower does not work no air or any heat either
the button on the ac unit one is the light is stuck on perminatly and the other is just stuck in

also there seems to be a burning smell when i lift the bonnet ummm am presuming this may be oil leak ??? as i had one on passat and it smelt smillar

also really poor mpg and the fuel is gauged is not too good either always seems to restart its self when engine goes off

any help or suggestion would be garetful and any ideas on cost to fix
i would really be graetfull :)

thanks

:confused::confused:
 

·
Registered
Joined
·
107 Posts
Discussion Starter #4
I have been reading and a guy on forum said if the pipe connecting to the rad is warm on start up then its the stat thats gone, and i have checked this and yes the pipe is warm even before starting car,

you reckon it be worth getting the sat and sensor changed and maybe a coolant flush done ???
as for blower would this be effected by this??
am learning lol

:eek::eek::eek:
 

·
Registered
Joined
·
9,912 Posts
I have been reading and a guy on forum said if the pipe connecting to the rad is warm on start up then its the stat thats gone, and i have checked this and yes the pipe is warm even before starting car,

you reckon it be worth getting the sat and sensor changed and maybe a coolant flush done ???
as for blower would this be effected by this??
am learning lol

:eek::eek::eek:
stat should be checked first thing in morning as in stone cold engine:thumbs: and if top pipe gets warm after start up say 5 mins of running stationary it will need replacing:thumbs:
 
M

·
Guest
Joined
·
0 Posts
I have been reading and a guy on forum said if the pipe connecting to the rad is warm on start up then its the stat thats gone, and i have checked this and yes the pipe is warm even before starting car,

you reckon it be worth getting the sat and sensor changed and maybe a coolant flush done ???
as for blower would this be effected by this??
am learning lol

:eek::eek::eek:
Does blower blow air (regardless of how warm or cold it is) in manual mode?

If it does a fecked stat may cause it not to blow on auto mode (climate control has a temp sensor at back of engine) It uses this to decide when to turn blower motor up in speed when engine is warming up.

The fact temp gauge is not lifting would fit with this if stat was stuck open.

Hope this helps
 

·
Registered
Joined
·
107 Posts
Discussion Starter #7
stat should be checked first thing in morning as in stone cold engine:thumbs: and if top pipe gets warm after start up say 5 mins of running stationary it will need replacing:thumbs:
arrr will do mate, thanks for the advice :thumbs::thumbs:
 

·
Registered
Joined
·
107 Posts
Discussion Starter #8
Does blower blow air (regardless of how warm or cold it is) in manual mode?

If it does a fecked stat may cause it not to blow on auto mode (climate control has a temp sensor at back of engine) It uses this to decide when to turn blower motor up in speed when engine is warming up.

The fact temp gauge is not lifting would fit with this if stat was stuck open.

Hope this helps
no air at all, buttons seem to be stuck in and broken, thanks for your help
i have to drive with window down to stop the car from steaming up lol

the car has been sat for 2.5 years,before i got it but has been in the family for 7 years

it could proberly do with a coolant flush ???


and thanks for your help am grateful :) :thumbs::thumbs::thumbs:
 
G

·
Guest
Joined
·
0 Posts
For temp control unit / air con
Do this:

1. Put the ignition key in "STOP" position
2. Turn temprature knob completely to the right (= max. temp)
3. Turn the blower knob to "0" position
4. Turn air direction knob to "mid direction" position
5. WITHOUT STARTING THE ENGINE, turn the ignition key to "MAR"
6. Turn the blower knob AUTO-0-AUTO-0
7. Turn the ignition key back to "STOP"
7. Now press the air-con button to turn it off.
8. Turn the ignition key back to "STOP"

Take two paracetamol and call me in the morning:rolleyes:
 

·
Registered
Joined
·
107 Posts
Discussion Starter #11
stat should be checked first thing in morning as in stone cold engine:thumbs: and if top pipe gets warm after start up say 5 mins of running stationary it will need replacing:thumbs:
Hello and good morning, I checked it this morming the pipe was warm after couple of mins
Not badly hot or anything, so it look like a new stat is need? How much is the labour charge to changed the stat ???

Cheers

Ste

Ps come on you blues today :p
 
M

·
Guest
Joined
·
0 Posts
Change it yourself....

Dead easy.. plenty of guides on here. should take about 20min on a TS. though to be honest find a good local independent garage if you can't do it yourself and it shouldn't be more than 30 min labour.

John
 

·
Registered
Joined
·
107 Posts
Discussion Starter #13
Change it yourself....

Dead easy.. plenty of guides on here. should take about 20min on a TS. though to be honest find a good local independent garage if you can't do it yourself and it shouldn't be more than 30 min labour.

John
I get local to do it lol do I need to charger sensor aswell ??
 

·
Registered
Joined
·
9,204 Posts
TS stat doesn't come with new sensor so it would have to be swapped or ordered with stat unit. Usually sensor is ok. I've replaced my TS's stat three times but sensor only once (2nd stat change).
 

·
Registered
Joined
·
107 Posts
Discussion Starter #15
Cool my local will do for £20 I've got to get the unit dou
Were best place to buy it ??
and it seems to be working today for first time lol
I've got lead comming from redbear I might wait see if that would help ??
Regards

Ste

Cars a!!! Are well at least takes mind off Everton lol
 

·
Registered
Joined
·
107 Posts
Discussion Starter #16
Hello, thanks to all the people that helped, ive know had the stat charged and the neediling is sitting were it should be,
even the heating has come on lol

any one know if the blower is good on thee 156 and should i get the aircon regas
if so any recomendations of were to go in liverpool ??? ie kwick fit ??

thanks people i love this forum :thumbs::thumbs::thumbs:


cheers

ste
 

·
Registered
Joined
·
9,912 Posts
Hello, thanks to all the people that helped, ive know had the stat charged and the neediling is sitting were it should be,
even the heating has come on lol

any one know if the blower is good on thee 156 and should i get the aircon regas
if so any recomendations of were to go in liverpool ??? ie kwick fit ??

thanks people i love this forum :thumbs::thumbs::thumbs:


cheers

ste
ill give you number of guy i used .....he is a professional but got to get it off guy who used to do my machine work tomorrow:thumbs: do not go to kwik fit!!!!
 

·
Registered
Joined
·
107 Posts
Discussion Starter #18
ill give you number of guy i used .....he is a professional but got to get it off guy who used to do my machine work tomorrow:thumbs: do not go to kwik fit!!!!
smasahing mate, takre your time mate am in no rush, like you said better getting it done properly :) and am just looking at the new red interior am trying to hangle for ummmm:):):)

ive got dignostic cable coming this week too, ohhh i can see the faults know lol

and did you lot no that as of april airbag light being on will be an mot failure ???

cheers

ste
 

·
Registered
Joined
·
9,912 Posts
smasahing mate, takre your time mate am in no rush, like you said better getting it done properly :) and am just looking at the new red interior am trying to hangle for ummmm:):):)

ive got dignostic cable coming this week too, ohhh i can see the faults know lol

and did you lot no that as of april airbag light being on will be an mot failure ???

cheers

ste
january i thought:confused:
 
1 - 20 of 23 Posts
Top