Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Hey all,
So far as I can figure I need a new thermostat. Temp while driving is rarely above 70 and only hits 90 when in traffic and idling for a while.

I also have an oil consumption problem. About 2 litres in 500 miles. I don't have any noticeable smoke and there are no leaks (I've been looking around for them and have had several nights of parking in the same spot wondering if I'd see any spots and there's none.)

I've taken off the breather hose and it's clean. I looked at the other one (which feeds the vapour separator?) and it had a very slight milky deposit.

As I understand it the inlet manifold gasket can be a source here but as I say - no sign of leak, no smoke, no smells.

Any ideas on next move?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #2
Nothing?
 

·
Registered
Joined
·
4,646 Posts
Hi there,

Thermo stat sounds like it needs replacing, from an auto factors they'll cost approx €40, takes approx 1 hour to replace.

iirc you are well capable of such work yourself, just rem to buy a few different sized jubilee clips to replace the original & take the battery out.... rem the radio code

oil: what oil are you using?

should be 10w/40 semi-synth .... if it wer emy ca ri'd buy a cna of bardahls engine flush, drive for 50 miles or so, then drain the oil & replace the filter with a new one & new 10w/40 oil & see how it goes form there

the max 'normal' oil usage is 1 L per 1000km [ 625 miles ] so yours is almost x2 that.

PS i was in 6milebridge last thursday colelcting a 2.0L ts that i bought
 

·
Registered
Joined
·
43 Posts
Discussion Starter #4
Only just did a flush and oil & filter replacement so that's not it. I've used Selenia this time round (10 W40) as I've heard some mention noticing a difference.
no improvement there I'm afraid.....

So there's something else and just wondering what my options are likely to be.. That is, i it's not any of the easy, known and cheaper fixes, where do I go from here....

Will the thermostat swap help (I know it's not going to cure completely)
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
at this point I'm seriously considering rebuild or replacement with a reconditioned unit....

It would really sicken me to replace considering I just had cam belt, waterpump and variator done. Of course it would sicken me to take out the original too....

At this point I'm wondering what to do......
 

·
Registered
Joined
·
314 Posts
I've got the same engine as you, and the temp is normally 72 degrees, increasing to 90+ in traffic. My car has burnt 100ml of oil over the past 6000 miles .... I was expecting a lot more :lol:
 

·
Registered
Joined
·
12,881 Posts
Your stat's start to open at about 82deg so anything below this is wrong ... of course the gauges are notoriously inaccurate and non-linear (also everyone assumes that the mark half way between 50 and 90 is 70 ... which it probably isn't) so I'd take what the gauge says with a pinch of salt ...

... Best bet would be to connect your car to alfadiag and get some readings about what temp the ecu is using ...
 
1 - 8 of 8 Posts
Top