Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
933 Posts
Discussion Starter #1
Slowly getting there with the retro-fit of the CD/DSP/SatNav/Telephone - although still waiting for the delivery of the subs... or even confirmation they have been sent :cry::mad::cry:

Has anyone else retro-fitted the telephone and/or DSP - or had to play around with the telephone wiring?

If so, do you know which speaker is utilised for the telephone and whether it is integrated within the standard speaker wiring to cone, or does it have separate wiring directly to the cone?

My standard set-up has just the telephone preparation which includes independant wiring directly to the cone of the passenger door main speaker (part number 60670881) as per the attached photos - the white clip on the back of the magnet feeding the red/black wires represents the telephone prep, the black clip at the top being the speaker system connection.

None of the DSP speakers or tweeters have this dual wiring set-up and according to ePER there are no speakers of any description listed that are intended for or have any telephone compatability (833 on ePER compatability chart) - so not sure what I should be looking for. :confused:

Any assistance, as always, greatly appreciated.
:thumbs:

Bob
 

Attachments

·
Registered
Joined
·
6,165 Posts
drivers side tweeter, but if your tweeter is working with music you dont need to connect. The ICS will send it when you get a call.
 

·
Registered
Joined
·
1,800 Posts
I have exactly the same set-up on my passenger door speaker and just thought I had a funny set-up! As a result I left this speaker in as I thought this white connector was some kind of special wiring up to the tweeter, so have my 'spare' DSP speaker lying in the garage. Does that mean that the white plug you disconnect from this speaker will just become redundant?

Who did you buy the subs from Bob? Are they on holiday at the mo or playing funny b***ers?
 

·
Registered
Joined
·
933 Posts
Discussion Starter #7
I have exactly the same set-up on my passenger door speaker and just thought I had a funny set-up! As a result I left this speaker in as I thought this white connector was some kind of special wiring up to the tweeter, so have my 'spare' DSP speaker lying in the garage. Does that mean that the white plug you disconnect from this speaker will just become redundant?

Who did you buy the subs from Bob? Are they on holiday at the mo or playing funny b***ers?
Scott, the connector is just for mobile telephone prep - basically your hands free kit would utilise that speaker for voice. So unless you have such a kit, whip it out and get that DSP speaker in - will sound much nicer :D

As for the subs, I'll hold back the "name and shame" at the mo, but it will be a month this Friday since I paid cash into their account and whatever the reason is, I'ts getting painful now - still only 2 seats in the wagon

Apparently, the initial delivery got returned as the packaging got damaged, but they were apparently retested and were fine. Apparently, they were then due to be sent, but apparently they weren't. Took a further 2 weeks to establish this.

Last "positive" response was last Wednesday when apparently, they were going to then be sent. Have sent and left 3 or 4 messages since asking for confirmation when sent and by what method, but no reply and nothing has arrived.

Left another voicemail this evening............. :(
 

·
Registered
Joined
·
1,800 Posts
Apparently, the initial delivery got returned as the packaging got damaged, but they were apparently retested and were fine. Apparently, they were then due to be sent, but apparently they weren't. Took a further 2 weeks to establish this.

Last "positive" response was last Wednesday when apparently, they were going to then be sent. Have sent and left 3 or 4 messages since asking for confirmation when sent and by what method, but no reply and nothing has arrived.

Left another voicemail this evening............. :(
FFS - what a nightmare. Hopefully you'll get them soon and get the car back together. I'll keep an eye out for any just incase. Do Autolusso have a pair? Last year when I chinned them about the other DSP stuff (the boot cage, as you know!) they did have a working pair. If I mentioned this before I apologise!!! :thumbs:
 
1 - 9 of 9 Posts
Top