Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
my brother in laws 2.4 jtd doe.s not start, mec suspects fuel pump failure,
this is not a common problem in the 2.4 10v jtd is it. second hand pump from breaker is
£200.
 
G

·
Guest
Joined
·
0 Posts
Fuel pump failures I have seen on an Alfa (all types) = 0

So what could it be? Well... What to try and how much it costs:

Try resetting the fuel pump switch under the passenger seat. =£ free

Try swapping over the fuel pump relay that is in front of the battery with another relay in there of same pin set up (same positions). =£free

Glow plug failure... Are you getting a current to them, if so... Try turning on the ignition three times and give 30 seconds per time in quick succession to make sure they are really hot then try firing it up... If no current is apparent , try the main fuses and relay. = £ free

Charge the battery off the vehicle overnight low amp/hr rate on the state of the battery despite its abilility to turn the car car over can have a bearing on starting.... i.e all the ampage is going into cranking the starter motor and flyweel , leaving no reserve charge for the ecu and fuel pump =£ 1.40 ish

Get your battery and alternator charge rate tested once the car has fired up and running to confirm... it's free to check at many tyre and exhaust centres
.
Make sure you are on flat ground and definately have at the very least 10 ltrs of fuel in the tank= £14 -£20 worth
Complete Crank Position Sensor failures that give the same symptoms Alfa Romeo 156 Sensor-Cranks =£36.00

If your mechanic hasn't suggested any of the above or even tried before blaming it on the fuel pump, find a new one that knows Alfa's.= £ Priceless
HTH
 

·
Registered
Joined
·
96 Posts
Discussion Starter #4
the mech told him that he put the car on the computer and it showed up low fuel pressure , but the h p fuel pump
is firing fuel out of it. does the fuel cut switch under the passenger seat cut the fuel of before the pump, or at the
ecu. looks like he may need to get a proper dia check with the proper alfa/ fait lead to see if the crank pos, sensor
is faulty.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #5
brother in laws jtd is now back running in all 5 cylinders, the spec,s said it was a sticking egr valve and a very
dirty fuel filter.
 
1 - 5 of 5 Posts
Top