Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7,768 Posts
Discussion Starter #1
Just about to remove my sump in order to fix my stripped thread on the sump plug. Have just bought the long reach Ribe sockets and got myself a helicoil kit. Now planning the reassembly and was wondering what if any is the knack for installing the sump after having removed it and cleaned the previous sealant/gasket from both sump and block face. What sealant/gasket is recommended for the sump? Also, after torquing is it advisable after having engine upto temp/24hrs later to retorque the bolts again?

Thanks in advance as always for the life saving advice.:)

PS: P1 2.0TS 16v 150bhp.
 

·
Registered
Joined
·
1,577 Posts
If its RTV it will take a lot longer than 24hrs to set at this time of year, unless you have a heated garage, or the engine is on a stand in the lounge!
 

·
Registered
Joined
·
7,768 Posts
Discussion Starter #6
Thanks fellas, ian my garage is full of junk and the only heating is my breath. :lol: So, i guess it will be off the road all weekend.:(:)
 

·
Registered
Joined
·
7,047 Posts
Be careful with the oil pump pickup. If you remove it make sure that it is properly tightened but definitely not stripped.
Most of the crank failures that come in happened after some numpty removed the sump and made a mess out of the pickup.
 

·
Registered
Joined
·
7,768 Posts
Discussion Starter #8
Thanks for the tip turbonutters. I have just looked at the workshop manual and other threads and while recommending removal off first nut and slackening rear nut on the pickup neither the manual nor other threads give a Torque on the Oil Pickup nuts, have you any idea or approximation on torque for these nuts?
 
1 - 12 of 12 Posts
Top