Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1,054 Posts
Discussion Starter #1
Hi All,

Ive have my 159 SW 2.4jtdm automatic about three weeks now. few foibles beginning to come out of the alfawork.

the background is: 08 plate, 85k miles, 2.4jtdm automatic. I have last week changed all glowplugs after a dashboard error message - which is now resolved so thats good. apparantly the car had the egr valve replaced previously - I think maybe 25k miles ago.

the symptons for diagnosis are as follows (I hope they are related but they could not be):

1) on cold start it starts and turns over no problem but stutters and coughs/misfires(?) for 3 to 4 seconds before settling. This is accompanied by a puff of i think whitishgrey smoke.

2) seems to be excessive whooshing from the turbo on boost at lower revs. Sometimes there is a squeeling/fluttery whistling sound. There is also what id say was excessive whooshing (Sometimes squeely) on overrun (like an over the top aftermarket waste gate dump valve thing or whatever its called)

3) there is a whirring sound when driving,fairly low tone. I cant decide if it changes with revs or speed as it drowns out at higher speeds. it reminds me of the whirring sound you get when an airbus takes off...i dont know why but thats what it sounds like to me

4) this may be in my imagination but for a car which will do 140 odd it seems to make more of a meal than it should over doing 100.

I should also add that this seems to have happened since ive had it - however may well have been underling from before but I just maybe had rose-tinted spectacles on! further - i cant imagine that any of these symptons can be a result of putting in brand new glowplugs? that the only thing ive done to it besides new bulbs and windscreen wipers.

The turbo seems to boost fine according to the dial and behaves as you would expect. My thoughts at this stage are an air hose, or turbo pipe or something.

Im not a mechanic and i only dabble myself in relatively straight forward things. Also not familar with this engine.

Any help or pointers or things to check would be appreciated :) - ideally with an idiot proof description/picture to what the part is im looking for.

Many Thanks! :D
 

·
Registered
Joined
·
4,802 Posts
stuttery start + misfire, excessive whooshing + whistling, (struggling with ...

Have a read of the diesel power loss guide in the stickies. It may be something as simple as a loose turbo hose. Could be more serious with the turbo vanes etc.
I'd also be wary of the EGR, as many people have been given reconditioned EGRs that fail rapidly.
Work through the list logically, at worse it may not resolve the issue, but could save you a fair penny.


Sent from AutoGuide.com Free App[/color
 
1 - 2 of 2 Posts
Top