Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
Yes, stupid me, started the car without freeing the wiper blades (frozen to screen and left the wipers on yesterday) and the wipers now only work on pulse (lifting the stalk up but no park) and on hi speed. , intermittent I'm not sure about, but standard speed dont work!!

So what do you thinks gone? do I need a new wiper motor, or is there a speed control unit I can swap out, and more importantly can I use one from a pre-facelift 156? (I have an 04 facelift 156)

Thanks in advance techies.
 

·
Registered
Joined
·
6,274 Posts
Sounds like the motor's goosed, or the electrical contacts in it.

The facelift cars use a different motor/linkage to the pre-facelift ones, I'm afraid. There's also a bewildering number of variations for some reason (10 for right-hand drive alone :eek:)!
 

·
Registered
Joined
·
1,377 Posts
I did it last year in my 147. Needed a new wiper motor. I feel your pain!
Although the pain of 187 quid fitted was worse! :(
 

·
Registered
Joined
·
440 Posts
Alfa romeo in Swindon quoted me £102.80 for a recon motor and 242.35 for a brand new one (motor and linkage).
Sorted the problem with the motor from a Fiat punto (Today) for £25.

Ric
 

·
Registered
Joined
·
1,377 Posts
your avin a bubble!! £187 quid, **** me:cry:
And that was cheap! A main stealer were after nearer 300 quid!

You'll only ever make that mistake once!
 

·
Registered
Joined
·
440 Posts
The wipers relay is on the back of the main fuse box
You have to remove the 4 bolts to gain access to it.
There is an electronic box on top of the motor in the wiper linkage (I think there is 1 or 2 small relays inside).

Ric
 

·
Vendor
Joined
·
46,595 Posts
this week i could have sold at least 10 wiper motors off th alfa im breaking for my wife
every enquirey seemed to be wiper motors
We've not got many 156 wiper motors left, had fifty of them boxed up 6 weeks ago.. Completely out of 147 wiper motors now as well.
 

·
Registered
Joined
·
440 Posts
Well I can repair the little buggers.
Need to get some spare parts because right now don't have any
Will post a picture from the one I can repair ( 156 )
But in principle all the ones made by Denso and marelli can be fixed.
PM me if you want to know more

Ric
 

·
Registered
Joined
·
200 Posts
i had the very same problem last year and repaired it with SEARS (thanks), there are three lives on the motor for different speeds ect from memory, all that had happend to mine is one of the lives had welded its self on, this was sorted by removing the end cap on the motor and releasing the bushes that were stuck on, this takes about 1 hour with giving all the linkages a grease up while your there:thumbs:

Worth a try mate, mine has been working for the last year with no problems now;)
 
1 - 18 of 18 Posts
Top