Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi.. Please help!!

On a trip to north coast, my car got stuck in 5th gear and wouldn't change! I tried all methods but it wont budge.. so i pulled up to the side and turned the engine off but it wont start again!! the dash shows 5th gear from the start. so got it towed.. its holiday season so the car is sitting at home.. is this gear box problem?? am i looking big bucks?? so scared.... please help~!
 

·
Registered
Joined
·
224 Posts
Of course its a gearbox problem - its a Sillyspeed.

Take it to an indie for them to have a look at, and buy a breakdown repair warranty in future.
 

·
Registered
Joined
·
29,994 Posts
How did they tow it if it was stuck in 5th gear...?

Can you hear the Selespeed pump running at all?
Presumably you have already checked the Selespeed fluid level?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
I took it to my friend's workshop.. and he said there is a fault with selespeed pump.. but the cost of part is up the roof and i might end up spending the value of the car.... so sad..
when i open the door, i cant hear any whizzing noise from the pump..
its dead silent..
the fluid level is on max and still cannot be started..
sitting for 2 weeks now......
 

·
Registered
Joined
·
42 Posts
Mine did that before and I thought it was the pump, after replacing it it oly turned out to be the thrust bearing. Just make sure you do proper test on the pump before you replace it. A lot of things can make the vehicle not change gears, i.e the thrust bearing, clutch plate, relays, clutch fork or the pump. Just be sure you got the correct problem and move from there.
 

·
Registered
Joined
·
35 Posts
This comment may be too late for you but check the battery condition. Low volts would stop Selespeed electronics and selectors from working correctly. Other false indicators may be simply caused by the low battery voltage.

Good luck...
 
1 - 7 of 7 Posts
Top