Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1 (Edited)
My idle fluctuates constantly and I can feel that the car misfires sometimes on idle. When I'm driving it feels good and drives normal. Checked the car in MES and I had a p0011 which is the exhaust solenoid. I changed both solenoids and nothing changed, it idles bad and the p0011 came back after a short amount of time. In MES I tried checking the desired/actual positions the solenoids should be giving and they were all over the place like the actual was 10-15 degrees off all the time. I ordered a new GM solenoid off Ebay yesterday just in case first time they gave me faulty solenoid and I'm praying that it was really just a faulty solenoid and it's not my chain stretching. What do you thing?

 

·
Registered
Joined
·
7,486 Posts
The needle's hardly moving??
I wouldn't be in the slightest bit bothered about that.
 

·
Registered
Joined
·
138 Posts
Dominik

I had a chain stretch which didn't throw an engine light. Symptoms, in my case, we lack of oomph. Driving uphill required a change to 3rd so I can either maintain the speed or accelerate. The car was a dog to drive and overtaking was a pain. If i press the accelerator to overtake the car would drop to 2nd gear and labor through the manouvre at high revs. So there was a lot of high revs, exaggerated, everytime I overtake.

Erratic idle, I never had. So don't think it's the chain.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Dominik

I had a chain stretch which didn't throw an engine light. Symptoms, in my case, we lack of oomph. Driving uphill required a change to 3rd so I can either maintain the speed or accelerate. The car was a dog to drive and overtaking was a pain. If i press the accelerator to overtake the car would drop to 2nd gear and labor through the manouvre at high revs. So there was a lot of high revs, exaggerated, everytime I overtake.

Erratic idle, I never had. So don't think it's the chain.
Mine doesn't feels like it lacks power or anything like that, it's just the idle. I really don't have an idea what it could be, it really weird.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #7
The needle's hardly moving??
I wouldn't be in the slightest bit bothered about that.
The thing that bothers me is that it's not idling smooth and i can feel that when i'm sitting in the car every time the needle slightly moves. All my other cars had smooth and steady idle, so this feels extremely annoying.
 
1 - 7 of 7 Posts
Top