Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
740 Posts
Discussion Starter #1
Calling all 916 owners......I have a problem with my beloved 916 spider.

It's a 2002 2.0 ts 916 spider.
Symptoms are...when the car is warmed up to about 60deg the throttle behaves weird. Firstly when changing gear it slightly over revs, secondly its not picking up as it should, like if you plant the throttle its not working! If that makes sence. The little car idles very smooths and drives perfect in all other ways.

Could it be the MAF or the throttle sensor!?
 

·
Registered
Joined
·
650 Posts
That could be a number of things. The quickest solution is to run a MES scan. That should eliminate the guesswork and point you in the right direction.

Download MultiECUScan from the innerwebs and get the OBD to USB cable from fleabay. Best bit of kit I have ever acquired.
 

·
Registered
Joined
·
740 Posts
Discussion Starter #6 (Edited)
Thanks guys. We have two obd's. Will have time on Saturday to pull the bonnet and check out my spider's little issue. I assume my throttle is fly by wire?
 

·
Registered
Joined
·
740 Posts
Discussion Starter #8
Thanks Andy to be honest this is the Only issue I have had on five years with this amazing little car. Other than suspension brakes exhaust and servicing it's been amazing. :) hope this is an easy fix though! Lol
 

·
Registered
Joined
·
942 Posts
If you need a replacement drive by wire throttle, I have one you can have for the postage :thumbs:
 

·
Registered
Joined
·
740 Posts
Discussion Starter #10
If you need a replacement drive by wire throttle, I have one you can have for the postage :thumbs:
That's very kind of you. It's so nice to have very helpful friendly and knowledgeable owners here on alfaowner. :)

My car seems to have 'reset' itself or something. I drove it home from work yesterday and all seemed normal, used car again today and fingers crossed all seems ok.

I checked the intake and the hose is remarkably in very good condition, no perishing or splits whatsoever. Wierd isnt it!

Well I plan to keep using the spider for a few day as my 159 Ti is having his wheels powder coated and four new boots as well! :)

The spider appears to have fixed itself! For now anyways. :) :) :)
 
1 - 10 of 10 Posts
Top