Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
379 Posts
Discussion Starter #1
Started the car yesterday and heard this strange tappet noise which is usually due to low oil level[ only heard at higher revs and not while idling]...But oil was fine,never below maximum..
Went and changed the oil,[ just in case,as I did not change it when I bought it last month :tut: and has driven 3000 kms since]..And the filter..
Used Castrol Magnatec 10W40 and the original Italian filter.
My mechanic told me to use the car about 50 kms and the noise will go...Anyone had such experience with the V6 ?:cry:

PS: The V6 takes 6.5 L of oil to reach maximum on the dipstick and not 5.9L as it says in the Alfa manual..:confused:
 

·
Registered
Joined
·
1,217 Posts
Started the car yesterday and heard this strange tappet noise which is usually due to low oil level[ only heard at higher revs and not while idling]...But oil was fine,never below maximum..
Went and changed the oil,[ just in case,as I did not change it when I bought it last month :tut: and has driven 3000 kms since]..And the filter..
Used Castrol Magnatec 10W40 and the original Italian filter.
My mechanic told me to use the car about 50 kms and the noise will go...Anyone had such experience with the V6 ?:cry:

PS: The V6 takes 6.5 L of oil to reach maximum on the dipstick and not 5.9L as it says in the Alfa manual..:confused:

Yep, this is normal and your mechanic is right. Drive for about 50km and the hydraulic lifters or something set in nicely and then the noise goes. This happened to me after changing the timing belts, tensioners and idlers on my GTA. Check also that you chucked in the correct amount of oil. My 166 uses 6.9 litres, and Magnatec is some of the best stuff ever made.. trust me. I have used it on my 2.0TS and she has 270,000km.. also my buddies in drag use it in their rotaries (13 b's) and they're making 400Kw at the wheels, of course though, they're using the other castrol edge stuff.. so i swear by castrol anyday...:thumbs:

cheers Dafi...
 

·
Registered
Joined
·
379 Posts
Discussion Starter #4
Cheers guys, relieved to know that it will set itself..
But is'nt it strange that Alfa sent an addendum to the 166's manual
stating that 5.9L is the maximum oil to put in the 3.0 and yet they all take different ammounts....My mechanic told me it all depends if it empties completely or not..If u manage to flash the whole system, you'll probably need around 7L....Weird world of Alfa..............
 
1 - 6 of 6 Posts
Top