Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
414 Posts
Discussion Starter #1
Hey everyone,

Lately my 156 1.8 ts is starting to make an awful noise as soon as the revs hit 3k, if i hold the revs at this point the noise continues but if i push on further it goes back to normal...

It sounds as if something is vibrating and rattling... hope its nothing too serious!

If anyone has experienced anything similar and could shed any light on what it might be it would be a great help.

Cheers

Dave
 

·
Registered
Joined
·
15 Posts
Could be the exhaust/cat bracket. Mine has a fast rattle/vibration @2200rpm. I haven't looked yet underneath yet, but a search of the forum tells you where and what to look for.
 

·
Registered
Joined
·
85 Posts
hmmm, my 156 was doing that, sounded like a top end rattle. Did it for a few weeks just before the bottom end went! 1 engine rebuild later, all is fine!

:)
 

·
Registered
Joined
·
414 Posts
Discussion Starter #4
hmmm, my 156 was doing that, sounded like a top end rattle. Did it for a few weeks just before the bottom end went! 1 engine rebuild later, all is fine!

:)
:eek: i really hope its nothing like that, dont think my bank account could handle it! Its going in for a new radiator soon so will have the garage take a better look at it... fingers crossed
 

·
Registered
Joined
·
70 Posts
i'm sure it will be the cat bracket. i made one out of stainless steel, but that broke as well, so now its off completely.....one year on nothing has fallen off!
 
1 - 5 of 5 Posts
Top