Alfa Romeo Forum banner

1 - 6 of 6 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Greetings one and all. I'm a new member to the site and what a site it is! Very impressed. Been reading through some of the old discussions and came across some good info. I am the proud owner of a '92 155 1.8 - white and nice. Moved to this from a pair of 33's, as some of you have also done. Couple of points though which you may be able to help me with.. any cures for the sticky drivers window - only does it on the way up?! Also, anybody ever had probs with a leaky power steering system. Every few days I get the old whiny sound come back which means it needs a top up - cant seem to FIND a leek but dont really want to change all the hoses if there is an easier solution. Any ideas?? :confused:
 

·
Registered
Joined
·
1,385 Posts
Word to the wise....I found my PAS leaking from the top of the pipe from the reservoir to the pump...the fluid dribbled down the pipe and ended up in the alternator...which is now knackered! It's going somewhere find it!!! Plus it has the possiblity of bursting at the worst possible time...just a friendly warning ;)
 

·
Registered
Joined
·
2,778 Posts
Sticky window cure usually seems to be a good dose of silicone spray down the window runners. I was convinced it was electrical (well, electronics) at first on mine, but after some suggestions (and not finding anything wrong with the control electronics) I tried the spray. After it had had a bit of time to work it's way round, the window has been fine. Root cause seems to be extra load caused by tired window runners makes the over-current bi-metallic trip on the motor operate. Then takes a few moments to cool off and reset. Of course, we keep pressing the switch so it never gets a chance to cool down.....

The 164 used to suffer with oil leaks from the rack into the boots...then eventually out onto the floor. Made tracing it tricky at first...same brand of rack (IIRC) so may be somewhere to check for the missing fluid.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Yeah, the fluid does appear to be leaking out from just below the reservoir. I think I may be quite lucky in that it doesnt appear to have made it to the alternator yet... bonus. Cheers for that. Windows are posing more of a problem though - just gonna keep trying the silicone til the can runs out!
 

·
Registered
Joined
·
56 Posts
My 16v had a power steering leak too. It dumped the whole lot in a carpark in a small Oxfordshire village (sorry!). There was so much fluid everywhere it was hard to tell at first where it had come from. I had to drive back to Central London without power assistance (very hard work). When I checked it out the next day, found that the hose from the rack to the cooler under the radiator ( I don't think the 8v has one of these ) had a small crack in it just under the battery (attacked by acid?). I bodged it with a piece of coolant hose from Halfrauds...that only lasted a few weeks before it became porous and started 'sweating' power steering fluid. Its now bodged again using see-through reinforced air hose...still seems fine after 6 months. The original Alfa hoses are £20 odd quid each for less than a metre length (2 required if you assume the other one is probably ready to go too). Despite trying many 'Auto Factors' have not found anyone who has the right stuff 'off the reel'.

My worry was that after driving probably 50 miles without fluid, the pump might be knackered, but touch wood its fine...

Mike.

(I didn't need to go to the gym for a week after that...) :D
 

·
Registered
Joined
·
18 Posts
Hi. I would like to ask about the power windows. mine make a terrible noise when I open or close the window (left and right one). so, is there any way to restore them to stop the noise?
 
1 - 6 of 6 Posts
Top