Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter · #1 ·
Had our Stelvio 2.2Td Speciale a week now and its good to see even the modern Alfas delight and disappoint in equal measure the same way all my other Alfas have.

Delight - Styling, interior comfort, power, handling. All the important stuff it as to be said.
Disappoint - stop/start works sporadically at best, rear wash doesn't, alarm goes off randomly and the most infuriating thing of all; the connection of a secondary, Android, smartphone.

Being used to a Merc E class, where the connection of 2 phones is seamless and similarly our outgoing Evoque, being pretty much unable to connect my Android phone as a secondary connection is driving me mad!!

When it all gets me down, I spin the DNA knob to D, floor it and see what G I can pull in corners. That cheers me up!
 

·
Registered
Joined
·
281 Posts
Stop/Start is down to battery charge once been running for a while it works fine, unfortunately now i dont commute to work and just make short trips it drains the battery. The Alarm is a well known issue and an easy fix at the dealers as they turn the sensitivity down or replace the whole module. Phone and washer i cant help you with.

As for the delightful bits you mention totally agree 100%
 

·
Registered
Joined
·
38,873 Posts
Had our Stelvio 2.2Td Speciale a week now and its good to see even the modern Alfas delight and disappoint in equal measure the same way all my other Alfas have.

Delight - Styling, interior comfort, power, handling. All the important stuff it as to be said.
Disappoint - stop/start works sporadically at best, rear wash doesn't, alarm goes off randomly and the most infuriating thing of all; the connection of a secondary, Android, smartphone.

Being used to a Merc E class, where the connection of 2 phones is seamless and similarly our outgoing Evoque, being pretty much unable to connect my Android phone as a secondary connection is driving me mad!!

When it all gets me down, I spin the DNA knob to D, floor it and see what G I can pull in corners. That cheers me up!
Did you buy new or used?
Start Stop issues are not unique to Alfa and relate battery charge. If you bought used then the previous owner didn’t bother to get the revised interior light surround with a reduced sensitivity part in.
 

·
Registered
Joined
·
172 Posts
Have had the alarm go off a few times for no reason. Will check to see if I can get the fix mentioned done.
Rear washer is fine on mine.
Do have 2 Android phones attached, haven't really tested as I am main driver and wife always with me, will check with her to see if she sees her phone connect when I am not there. She hasn't complained yet... :)
S&S had o get new battery under warranty for it to work.
 

·
Registered
Joined
·
38,873 Posts
If you don’t many miles then the charge levels will not reach the parameters where the car will consider it a good idea to switch off. Mine doesn’t and other brands would’ not either!
And it has four wheels! Also typical of Alfas.
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #6 ·
Thanks for the replies.
I charged the battery yesterday to full and the S/S was still sporadic, maybe that's how it is.
I managed to pair my Android phone, audio and phone, but as soon as the car was switched off, it lost the connection and was a trial to connect again.
I bought used and the used car dealer was not open to any form of discount or acknowledgement of issues, and due to it being the only one in our price range and spec we wanted, we were held at ransom for it!

Having said all that, I drove 80 miles to Brighton and back in it last night and all the woes were forgotten!
 
1 - 6 of 6 Posts
Top