Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
Hey guys

Does anybody know how to get those plastic covers off the buttons?

When I press the volume up button the radio keeps muting, so I want to check if there's any muck under the buttons.

I've tried pulling them a bit but scared i'll break them.

Any clues?
 

·
Registered
Joined
·
519 Posts
I would be surpised if the issue is at the wheel.

Their is a plug containing all the wires that goes to the stereo but if the map is not the same between the stereo and the head unit then you will get incorrect buttons or loss of function.

I needed an adapter to convert the plug for the controls to the correct map for my head unit. It was a Blaupunkt head unit and they made the cable (they also supplied the OEM head but I still needed the cable that changed the map).
 

·
Registered
Joined
·
1,811 Posts
Mine did at one time do the same, however the controls were replaced under warranty because the buttons had worn around the edges.
 

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,713 Posts
from memory (of browsing the workshop manual) you first need to remove the airbag. that involves disconnecting the battery (for at least 15 min to avoid an airbag error next time you turn the car on), carefully unscrewing the bag from behind the wheel, then accessing the buttons from there.

:)
 

·
Registered
Joined
·
14,575 Posts
Definatly dont try and pull the buttons out:tut:
 

·
Registered
Joined
·
275 Posts
Discussion Starter #6
Ok maybe i'll leave all that for the dealers to do.

Knowing my luck the airbag will probably blow up in my face :lol:
 

·
Registered
Joined
·
14,575 Posts
Ok maybe i'll leave all that for the dealers to do.

Knowing my luck the airbag will probably blow up in my face :lol:
:lol:
 
G

·
Guest
Joined
·
0 Posts
It's easy. You don't need to disconnect anything as you don't need to unplug the airbag.

Unscrew it and rest it on the wheel, be careful.

Then, with a sharp knife wrapped in a cloth, you can prise each button mount off. Beware though, although they have only been pushed into the wheel, they have a hook sort of design and a bit of glue, so need a bit of a tug.

When the switches are off the wheel, they can be prised apart and easily and checked etc.

Alternatively, I have both sides, in pretty good condition, both fully working and ready to go...................
 
1 - 8 of 8 Posts
Top