Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Hi my 146 makes a funny sound like a dull flat sweek when i turn the steering when going very slow or stationary .It does it also only when pulling away and is fine when going normal speeds .Could anyone be so king as to point me in the right direction to solve this annoyance lol . Many thanks Chris
 

·
Registered
Joined
·
51 Posts
Discussion Starter #2
Hi could anyone let me know what noise the drop links make when they need replacing .My car is making a dull creak when going slow or turning .No knocks or bangs when going and the tyre wear is perfect and the car drives spot on even under braking its straight and true jusst the bloody car park speed creaking lol .

Are the drop links easy to replace ? And lastly if the balance belt breaks does it knacker the engine like the timing belt ? I ask because I had the belt replaced last week at 80 k and my mate forgot to replace the balance belt lol .

Many thanks .

I have had the offer of a 147 gta with 18k on the clock in mint condition . Can anyone give me the lowdown on the 147 because I would need to sell my bike and Skyline to buy it . Bloody Alfa's are like a drug and Iam addicted lol
 

·
Registered
Joined
·
7,115 Posts
the drop lonks do not rattle like the 147/156 as they have rubber in them ather than a ball joint, so do not make much of a sound, the handling just becomes a bit sloppy and rolly on cornering.

The balancer belt will take out the cambelt if it lets go, so make sure he does the tensioner as well as the belt.

Lots of advice on the 147 GTA on the GTA section, the cambelts do not seem to last long on the 3.2s for some reason, 2.5 and 3.0 seem to go at 60/70k if left, the 3.2 seems to be nearer 40k for some reason. Lots to choose from so buy the best you can.

Bloody Alfas, you can't live with them and....... :D
 

·
Registered
Joined
·
31 Posts
Squeek

If you mean that it makes the squeek when turning the steering at slow speeds,parking or stationary, that will be the power steering pump,mines has been doing it for the last 25000 mls. so don't go rushing out and replacing it, coz it will be expensive.
 

·
Registered
Joined
·
1,929 Posts
And a huge Pain the the **** to change!
 

·
Registered
Joined
·
51 Posts
Discussion Starter #6
Cheers .I would say the noise is like a dull creak or a dry rubber . It only does it when going slow and seems to be coming from the front end .It does not do it if i push the suspension up and down ,just when i turn the wheel or move of or pull up slowly .

Have said yes to the 147 and have convinced the wife the Skyline has to stay as its an investment lol .
 

·
Registered
Joined
·
51 Posts
Discussion Starter #8
I have just had the car up on ramps and checked all the bushes and as far as I can tell the lower arms are both new as are the bushes .The drop links look and feel ok so I deduced it must be the ARB bushes .Would the ARB bushes make the deep squeeking noise and if so is it easier to change the whole Arb as they are only 60 quid inc bushes for genuine Alfa parts .Do I need to drop the sub frame or is there an easier way ? Many thanks .

Took the 147 gta out today and its a beast but I hate the traction control and the understeer is horrific .I think I will try a set of P zero's and maybe a set of adjustable Konis to try to dial it out as it seems far to sloppy .
 

·
Registered
Joined
·
39 Posts
same thing

i have the same problem with squeaking, does sound like dry rubber rubbing together, have looked at everything but cant pinpoint it, on drivers side, when turning left or on low speed, if full lock left at low speed, i.e going round in tight circle, turns to more of a grinding with loud rubber noise, all joints are tight and no movement, really annoying me.

plus anyone no if you can get hold of the headlight adjusters, the last owner broke them so my headlights have droped and wont move up???? dont really want to pay 200 quid for whole new headlights.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #10
Hi I have given up on the rubber sqeak thing .We have replaced all the bushes inc ARB and its still the same lol . I guess its just another Alfa quirk .

I may be able to help you with the adjusters ,I am in the process of getting a 146 ti donar car .I will let you know if the deal goes through later this weekend .

:p
 

·
Registered
Joined
·
1,929 Posts
Strut top mounts then? Crushed bearings?
 

·
Registered
Joined
·
19,792 Posts
Dull flat squeak?

It'll be a mentally challenged squashed mouse caught in the steering rack.
 

·
Registered
Joined
·
2,777 Posts
i suggest it might be the power steering pump. mine is sometimes whining, then the rubber noise. lately has been more the rubbing noise only parking or on slow motion. i'll be changing the power steering pump soon, so i'll drop some news ;)
 

·
Registered
Joined
·
51 Posts
Discussion Starter #15
Hi it was the top bush .I replaced it today with a new upper arm and its quite again lol .
The donar car is coming on Monday so I will let you know about the light adjusters then .

Does anyone have a nice set of 16 or 17" rims for sale ?
 

·
Registered
Joined
·
51 Posts
Discussion Starter #19
Hi sorry I made a mistake the parts to stop the clunking sound are the strut top bearings .I can get them for both sides from Partco Louth Lincolnshire for £49 inc vat .They transformed my car .I find myself driving the 146 more than my 147 gta as it far more chuckable and less of an animal lol . The donar car never turned up .
 
1 - 19 of 19 Posts
Top