Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Last day i parked my car and everything was just fine. After 3 hours i strted the engine and when i turned the wheels it was a weird loud noise. It was there on idle but very low and it was really loud everytime i was turnimg rhe wheels. I read a lot around here and i suppose its the steering pump. I think the noise was on the belts that give motion to the pump?? After i turned off the engine fluids start get out of the box that containd the steering fluids. It had many bubbles when i opened it to see if there was any fluid left in it.
My engine is 1.9 jtdm and the fluid colour was green light to yellow.
 

·
Registered
Joined
·
635 Posts
Install a new reservoir, there is a filter in it that can get cloged or get loose, and take a look at the colour of your fluid, can be conterminated.
Should be green but can allso be red.
When its brown you need to replace it.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #3
No brown colour. Its a light green one. I mostly posted this thread just because in my case it started in sudden and really loud. More about your opinion if this is something different. Tomorrow im going to the mechanic and i will ask him replace the reservoir and rhe fluid.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #4
Well... Here i am. The mechanic says that its the pump that has a problem. He finds weird that the liquid in the reservoir was full of bubbles. Does anyone knows what that could mean? Im trying to find a new pump or a used one but i need the part number. So my second question is if anyone knows it... Thanks in advance l
 

·
Registered
Joined
·
635 Posts
That happens to when the filter in the reservoir gets loose, or is conterminated.
Then you get frothy power steering fluid.

A new steering pump isnt cheap, i think a €1000,- where i live (new pump) that is with flushing the system and instelling it at a dealer.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
All i read here and your advice says to me to insist on changing first the reservoir and the fluid. The fluid although has a good colour shouod be changed all of it, right?
 

·
Registered
Joined
·
635 Posts
When the colour looks ok then i would start with only replacing the reservoir.
And when you change the fluid then all of it
 

·
Registered
Joined
·
70 Posts
Discussion Starter #8
After turned off the engine some amount of the liquid got out of the reservoir although it was closed. So i believ it will need some liquid to be added
 

·
Registered
Joined
·
70 Posts
Discussion Starter #9
This is a Bosch part number and supposed to be fitted in 159 1.9 jtdm. K s01 000 115
Is this the right steering pump? Just to be sure
 

·
Registered
Joined
·
70 Posts
Discussion Starter #10 (Edited)
This is a Bosch part number and supposed to be fitted in 159 1.9 jtdm. K s01 000 115
Is this the right steering pump? Just to be sure
Is it the right one? Does anyone know?
I have mistaken about the fluid. I took off the fluid from the box and it was brown... So i suppose it was the red one at first. I ordered a new reservoir and they sent me a wrong one, i think it was for the 2.2 jts model. So now i have 2 problems, one about the fluid that i believe im not able completely change it on a green one on my own. I cant remove the old red fluid completely and mixing them even a bit i suppose will cause only problems. I only managed syringe out the fluid in the reservoir but there is more in the hoses under the reservoir. The sexond problem is that i have to stay a bit more with the old reservoir with no filter on it. Any suggestions?
 

·
Registered
Joined
·
635 Posts
There is a returnhose that goes back in to the power steering reservoir, detache it and hang it in a bucket, then you have to make sure the reservoir stays toped up with new fluid and then you start the engine till it gets clear again.


Thats an example and get the right reservoir
 

·
Registered
Joined
·
70 Posts
Discussion Starter #12
Thats more than clear and something that i can do alone i believe. Im waiting the new reservoir from uk... Here in Greece i could find only used. So when it will arrive im gonna try it. Thanks a lot for your help.
As for the pump i was asking about the part number in vase this will not solve the problem and i have to go on to the next step. In this case i will need a new pump and here i will find used pumps in the price of new in online markets.
 
1 - 13 of 13 Posts
Top