Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter #1
Hi people. As the title reads my steering makes a cracking noise. It happens mostly at low speeds or when parking. I managed to make it almost disappear a few months ago by filling up with oil the steering rack but I've just made a long trip and the noise is back. Everything works fine and you almost dont feel it in the steering wheel but it sounds a lot. Does anybody have a clue what could it be? Im gonna take the bella for a revision soon and I would love to get this fixed. Thanks and happy Christmas to all!
 

·
Registered
Joined
·
274 Posts
Discussion Starter #4
Upper strut mount/bearing(s) is maybe knackered.
It could be, but why did I make the noise disappear by filling up inside the steering rack with normail oil? The oil came out slowly everytime I was turning until it was empty again but the noise didnt come back then, it took almost a year. Looks like something gets dry and stucks inside the steering.

Is the steering fluid low again? If so its a slow leak

Sent from my E10i
I never filled up the steering fluid and the steering is not any harder than before so I dont think this is the problem.


It has to be something around here, thats where the noise comes from
 

Attachments

·
Registered
Joined
·
1,164 Posts
Excuse me but I assumed by your first post that you had topped up the steering fluid and the level was OK now but the cracking noise had come back, were exactly did you fill with oil ? if it where at the track rod fittings/ball joints it must not be oil there but grease, with the oil you have probably washed away the grease so the ball joints are maybe working in dry now and may be worn, try to grease them with MoS2 grease and see if it helps or just change the track rods if that is where the noise comes from.
 

·
Registered
Joined
·
274 Posts
Discussion Starter #7
Excuse me but I assumed by your first post that you had topped up the steering fluid and the level was OK now but the cracking noise had come back, were exactly did you fill with oil ? if it where at the track rod fittings/ball joints it must not be oil there but grease, with the oil you have probably washed away the grease so the ball joints are maybe working in dry now and may be worn, try to grease them with MoS2 grease and see if it helps or just change the track rods if that is where the noise comes from.
Lol, Im glad Im not that bad. Im sorry I cant explain it better. I didnt touch the steering fluid tank, is fine. I didnt touch the ball joints either, I know they run on grease and thats not where the noise comes from. I filled up the steering rack through the bellows, actually it was a friend from a great garage who did it so I know for sure we werent doing anything wrong. If you check the picture the oil came in through the bellows on the sides and the double acting piston pushed it out afterwards, with every steering move. It really sounds as if the piston wasnt moving so freely or the torsion device had some kind of problem.
 

·
Registered
Joined
·
274 Posts
Discussion Starter #8
Sorry I assumed the same... Don't know whats up here

Sent from my E10i
Me neither. I've been reading through the forum but I couldnt find any similar problem, nobody has a cracking noise in the steering as I do. I dont think is anything too serious as everything works perfect and the noise disappears if I inject some oil inside but I would love to get it fixed. When I park the people around they look at me as if my car was gonna break into pieces any second.
 
1 - 8 of 8 Posts
Top