Alfa Romeo Forum banner

1 - 7 of 7 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I'm sure most of you are bored of threads like this, but it's driving me slowly mad! I cured my front suspension noise recently with new drop links and upper wishbones, but now I have a squeak from the rear! At first I thought it was internal, but after removing the front seats and oiling them, pulling apart the rear seats and even oiling the boot stops, I'm sure the squeak must be suspension related. The problem is that it's terribly inconsistant, doesn't occur on the same bumps all of the time and happens sometimes in the dry and sometimes in the wet! I got the car on a ramp today and sprayed copious amounts of silicone around all of the rear suspension elements that contain a bush, ie most things, but the noise is still there. Is there an inherant rear suspension part that squeaks over time, the same as the issue with the front end squeaks, which nearly always points to upper wishbones??? On a sidenote, I hope everyone that went to the Alfa meet today had a great time, and the weather held out!
 

·
Premium Member
Joined
·
621 Posts
I have a similar thing, just about stripped out the back of the car, up and down the road all day long seeing if the last squirt of lube did anything, and its still there, Im sure its in the car, sounds like a mouse sqeaking, does it now and then and not always on the same road/bumps. I have given up and turned the CD up!!!
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #4
They made 'proper' adds in them days! Driving home tonight I'm sure once again that it's inside the car, but god knows where! The search continues:rolleyes:
 
1 - 7 of 7 Posts
Top