Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
576 Posts
Discussion Starter #1
Our passenger seat heater is not working, ive checked the fuse and its ok. Any Ideas or should I just wait till service time and leave it to the dealers?
It might never have worked! Just tried to use it for the first time last week. The drivers works fantastic, even warms your lower back too.
 

·
Registered
Joined
·
972 Posts
What a time for it to fail! If you're married, it might be best not to draw attention to the fact that your seat is lovely and warm......just a thought :lol:
 

·
Registered
Joined
·
576 Posts
Discussion Starter #5
What a time for it to fail! If you're married, it might be best not to draw attention to the fact that your seat is lovely and warm......just a thought :lol:
Unfortunatley she already noticed it! :D
 

·
Registered
Joined
·
280 Posts
Had the drivers side fail on my previous 159. Fixed by dealer under warranty, but they did have to take the seat out to do so.
 

·
Registered
Joined
·
260 Posts
Got 3-stage (whatever that means as have not bothered to read the manual! LOL!) heated seats...how long do they take to heat up fully?
 

·
Registered
Joined
·
576 Posts
Discussion Starter #9
Got 3-stage (whatever that means as have not bothered to read the manual! LOL!) heated seats...how long do they take to heat up fully?
just a minute or two.
Its just a roller switch with 0123 on it! different stages of heating. When it works its excellent!
 
1 - 9 of 9 Posts
Top