Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Alfa Romeo 916 Spider phase 1 2.0 TS
Joined
·
8 Posts
Discussion Starter #1
Initially I had issues as my roof was fully open and I could not close it even though the motor was rotating. For that reason, with help from the forum, the suspect was that the nylon gear of the motor was seized. I have ordered a new aluminium upgraded version. In the meantime I removed the motor and inspected the internals. All was working OK. No seized gear at all. I removed everything and re-installed it, re-tightened the locking cables and started to close the roof. Now it worked! No idea why. Anyhow because of the good weather I opened the soft top again and it opened fine. However when I closed it later on the roof stopped almost at the end about around 6 inches away from the hatch. When I checked the locking cables on the motor lever I noticed they were very loose in the closing position. I cannot tension the cables more as they are already at the end of the adjustment. I am sure this was not as before. I presume the cables got loose from the locking devices under the hatch. I am hoping you know what I mean but I have no clue why this cable tension on both cables changed. Any idea what this is and how to repair it? Thanks in advance!
 

·
Registered
Joined
·
2,359 Posts
The clamshell locks need the cables to be tight to lock. If the clamshell isn’t locked then the back of the hood will be holding it down which may be related to the problem. Also, check the fluid level in the reservoir.
 
  • Like
Reactions: alexx230
1 - 2 of 2 Posts
Top