Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My engine has decided to stop working. while out for a drive engine oil light flashed on and then cut out at traffic lights. unable to start cam belt ok. even tried removing plugs putting into gear and rocking car engine won`t turn at all. oil level fine. AA man thinks bottom end seized. Am I best to replace engine or repair.:cry:
 

·
Registered
Joined
·
4,932 Posts
Take the Aux belt off and make sure the alternator hasn't seized. That can happen.

If the oil light was on then most likely the engine has seized. How long was it on for and if it was on for longer than a few seconds then why didn't you switch the engine off immediately?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
The engine light just flashed on and engine stopped immediately. light was on for a second only. I will check alternator. Cheers
 

·
Registered
Joined
·
117 Posts
Could be oil pump failure? If its seized then looks like crank grind and new shells. Or swap engine for good used one or short one. Either way engine out job, belts off, sump off etc.

Hope it's not that though! Good luck.
 

·
Registered
Joined
·
212 Posts
Sounds like your oil level had gotten too low and its seized, especially if you cannot get it turn over by rocking the car in gear.
I would go for a 2nd hand replacement engine. Keep your ancillaries to swap over. The engine has to come out either way, so go for a known good engine, it'll be quicker & cheaper in long run.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Thanks Luckydog, I think an engine change would be best. As for the oil level it was just below max so a bit puzzled about that. Let you know how I get on..
 
1 - 10 of 10 Posts
Top