Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7,768 Posts
Discussion Starter #1
Hi Alfisti,

can someone verify or correct me please!?

The two special tools i need to remove the sump on a Twinspark are ...

M8 x 240mm and M7 x 200mm.

Thanks in advance as always.

ER.
 

·
Registered
Joined
·
8,916 Posts

·
Registered
Joined
·
7,768 Posts
Discussion Starter #3
Thanks Mitch, i have a clearance sale at a local auto supplies shop and he has the Long Ribe sockets in stock including M7 200mm and M8 240mm for a £5 each so i was checking they were the correct ones as his sale prices are too good to refuse.:)
 

·
Registered
Joined
·
9,490 Posts
At that price I'd buy up his stock and make a small profit selling them on - especially as TotallyAlfa appear to be AWOL at present, judging from a few comments on here......
 

·
Registered
Joined
·
7,768 Posts
Discussion Starter #5
Crikey! I do hope that TotallyAlfa are still active, i did speak on the phone to those guys late Oct and they were back after the summer and now am begining to wish i had spent the money on tools then rather than considering buying them now! Fingers crossed they are just having an extended Christmas break!?
 

·
Registered
Joined
·
396 Posts
can i please have that number? I'm one of the guys that ordered a fairly big order mid-dec, not responding to emails, another aussie put in a PP dispute - no number listed on the website...

Will have to put in my PP dispute soon, 7 days or so left to lodge...

cheers

Joe
 

·
Registered
Joined
·
4,627 Posts
I placed an order around last May and it took a good couple of months to arrive.

He was responding to emails promptly at that time.
 

·
Registered
Joined
·
396 Posts
just got back to me on his totally alfa email addy:

Hi Joe

Your tools will be despatched tomorrow morning. Just been waiting for the pulley puller to be finished off, sorry for the delay.

Regards

Gary

keep u guys updated
 

·
Registered
Joined
·
396 Posts
totallyalfa = totally good

in case this was being followed - just a note to say i got everything ok. totally alfa are running as per normal..

good news for DIY alfisti!!:thumbs:
 
1 - 11 of 11 Posts
Top