Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter #1
Hi,

The other day, I left my keys in my gf car... I went to use my spare key - the remote lock didnt work but i could unlock the car manually. As soon as i opened the door the alarm went off. I couldnt get the key to start the car either.

SO got my gf to drive back with my original key which worked.

My question is why wouldnt my spare key work - is it just a case of a new battery in the key? or does it need to be coded??

Its a 52 plate ts 156

any ideas would be a great help as id like to have a spare key that works!
 

·
Registered
Joined
·
5,266 Posts
Sounds like your spare key is actually a key for another car thats had a new blade put into it. Or possibly it wasn't present when the car was programmed to accept a new key and was therefore deleted.
 

·
Registered
Joined
·
49 Posts
try the battery first see if that works,there is a small part in the fob that is the immobiliser this stops the key working if its not paired with the car,not sure but i would have said if the door was opened the key must be the correct one for the car?
 

·
Registered
Joined
·
30,074 Posts
try the battery first see if that works,there is a small part in the fob that is the immobiliser this stops the key working if its not paired with the car,not sure but i would have said if the door was opened the key must be the correct one for the car?
It only means the blade is correct.

The key battery is only for the remote, not the immobilizer.
You should still be able to start the car even with the key battery removed.
 

·
Registered
Joined
·
200 Posts
Hi, I'm having similar problems to you.

Test your key by the following

1) unlock car from the button of the working key

2) leave working key in house and get in car with faulty key

3) Try to start with faulty key, it doesn't matter if battery is in it or not

If the engine turns over but doesn't start, look for the word "code" in the warning lights, if that shows it means the key isn't programmed for the car and you will have to re-program it, which is around the £45 mark from main dealer
 

·
Registered
Joined
·
3,480 Posts
If the engine turns over but doesn't start, look for the word "code" in the warning lights, if that shows it means the key isn't programmed for the car and you will have to re-program it, which is around the £45 mark from main dealer
A key that had its immo chip programmed already, can not be reprogrammed (for the immo function).
 

·
Registered
Joined
·
2,627 Posts
If you're desperate, take the good immobiliser chip out of the key and tape it inside the steering cowl. Then both keys will start the car. Of course you will effectively have no immobiliser function.
 

·
Registered
Joined
·
193 Posts
Discussion Starter #10
Hi, I'm having similar problems to you.

Test your key by the following

1) unlock car from the button of the working key

2) leave working key in house and get in car with faulty key

3) Try to start with faulty key, it doesn't matter if battery is in it or not

If the engine turns over but doesn't start, look for the word "code" in the warning lights, if that shows it means the key isn't programmed for the car and you will have to re-program it, which is around the £45 mark from main dealer
I will attempt this at least that way i might find an answer. So the battery in the key fob only powers the remote locking ability ? Is that correct ?

Thanks for all the responses -
 

·
Registered
Joined
·
193 Posts
Discussion Starter #11
Right, Just unlocked car with working key, left that in the house and the spare key started the engine fine. No warning light or anything just like it should.

Why do you think it triggered the alarm before after opening it manually with the spare ?
 

·
Registered
Joined
·
30,074 Posts
Why do you think it triggered the alarm before after opening it manually with the spare ?
...... if the alarm is armed and you unlock the door using the key in the lock the alarm will obviously go off when you open the door!
 

·
Registered
Joined
·
1,581 Posts
Can I just resurect this post with the following question.

I have 2 keys, the spare key will start the car, unlock everything manually. The light on the key goes on when you press the button but nothing else happens?

What could be wrong?
 

·
Registered
Joined
·
30,074 Posts
Can I just resurect this post with the following question.

I have 2 keys, the spare key will start the car, unlock everything manually. The light on the key goes on when you press the button but nothing else happens?

What could be wrong?
Not paired with the alarm/remote.
 

·
Registered
Joined
·
1,581 Posts
Is pairing easy or an Alfa main dealer job. My old car you could hold the button with the key in the ingition for 3 secs and it would pair.
 
1 - 19 of 19 Posts
Top