Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have a Mito 155 and during the past few months I have noticed that the car makes a noise from the rear suspension. The noise is not loud or squeeky. It is more of a low frequency noise, if I can put it in words it would be ''gloup". The ride is not affected at all. Has anyone got the same sound coming from the rear syspension?
 

·
Registered
Joined
·
573 Posts
just to clarify - is the "gloup" noise happening when you go over a bump?

Have you checked your spare wheel is locked down tightly?

is it the parcel shelf jolting?
 

·
Registered
Joined
·
65 Posts
My 95bhp has also developed a weird noise from the rear suspension over the past couple of weeks. It doesnt happen over every bump, and is much more evident at around 10mph to 30mph.

I'd more describe the noise as a rattley clunking sound, almost like something is loose. I've checked the back seats, parcel shelf, empted the boot, looked under the car etc but cant find where the noise is coming from. Not checked the spare wheel but will do later.

The car goes in to the garage tomorrow to get checked over. I'll let you know what they say :)
 

·
Registered
Joined
·
65 Posts
My hearing must be playing tricks on me in my old age. Turns out the noise was coming from the front, not the rear.

Just had the garage on the phone saying that they had to replace the offside anti roll bar drop link as this is whats been causing the noise :)
 
1 - 5 of 5 Posts
Top