Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Hi!
I've recently jumped ship from a Mito QV to a Giulietta Veloce 2L diesel tct. Loving the car so far!
However I do have a few issues/questions.

1. Start stop. Had the car 3 weeks and not once has it come on. Im aware that climate control, engine and outside temp has a deciding factor as to whether or not it will activate but really, not once?
Question I ask is how does it actually work on the tct? Do you have to use the handbrake or something? My understanding is that I'm one of the lucky ones if it doesn't work! I never get a message on the dash saying it's unavailable or anything it just doesn't..work.

2. Boot release button on the actual boot stopped working after the car was washed for the first time. Opens with the button on the key ok. I tried the installation sequence in the manual but no..
I have extended warranty so I will give them a call unless anyone has any ideas or similar experience?

3. Recall campaign. My car is a 2012 model, Had it serviced today and apparently I need to take my car to an authorised Alfa dealer to have some wiring for the transmission pump moved.
Question is are they going to charge me for this seeing as it wasn't done in good time by the previous owner? If so has anyone else had this and how much does it cost? If it's a million pounds and I don't bother having the work done will my gearbox explode or something equally dramatic that will cost me 2 million pounds rather than the initial 1 million!

4. ERG delete offered my autolusso. Im think of doing it, anyone else recommend this?

Thanks in advance for any replies and advice!
 

·
Registered
Joined
·
8,786 Posts
youdon't need to do anything for S/S to work in the tct, except put your foot on the brake.

they won't charge you for recall work, ever!

boot release acted up in the beginning on my car, but has been fine since. Same issue as you, never did anything about it but it juststarted working again after a few days and hasn't happened since.

egr delete... I would be interested how this affects engine warmup times....
 

·
Registered
Joined
·
103 Posts
Discussion Starter #3
Ok, might test my battery as that was my start stop issue on my mito. Although should I be grateful it doesn't work? Is it more of a pain or does it really save on fuel?

I hope your right about it being free, this is the same dealership that wanted £595 for a service.

I'm going to leave the boot a couple of days and see if it goes away. Might be a little water from car wash.

I'm going to wait to hear others experience after ERG delete
 

·
Registered
Joined
·
8,786 Posts
I've turned off S/S upon reception of the car, and it's still off. Sometimes I turn it on briefly as it's a good way to check battery condition.

Check if you have an AGM battery fitted.
 
1 - 4 of 4 Posts
Top