Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13,236 Posts
Discussion Starter #1
My sunroof hasn't worked for ages. I tried a new switch last year and the fuses/relays seem to be okay and there's a live circuit in there... Anyway, it was winter and all that so I just left it.

This weekend (baking 28 degrees) I just pressed the switch (don't know why) and it worked! It went back and forth, up and down. I opened it closed it and drove about all day and it was fine. Cool!

Then I parked up with the roof open. Went back a few hours later in the evening to close the roof and ... it didn't work!

What was that film with Robert DeNiro as the dude who was in a coma for 30 years till the doctor (Robin Williams?) gave him some new drug... that's what my sunroof feels like.

Does anyonehave any cluse what might be causing it, given the symptoms?

Ralf S.
 

·
Registered
Joined
·
4,651 Posts
Proably a bad connection either in the wiring to the motor ar the motor itself

Is`nt there a way to wind it shut on the motor mechanism i seem to remember Andymac having to do it a while ago..................maybe a search is in order :D
 

·
Registered
Joined
·
6,920 Posts
There is a key on the other side of the cover that covers the sunroof motor, i discovered this by accident when trying to stop the interioir squeaks of a 155, its the cover in front of the main interior lights BTW, you wil just need a srcewdriver the leaver it out! :D ;)
 

·
Registered
Joined
·
13,236 Posts
Discussion Starter #4
Yeah... there's a key under the htach that lets you open and close the roof if it sticks open but I'm more worried why it's doing this "Awakeinings" (?) impression every so often.

And why I had the sudden urge to press the sunroof switch, which I hadn't used for 6 months...!

Spooky... :eek:

Ralf S.
 
1 - 4 of 4 Posts
Top