Alfa Romeo Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
2,890 Posts
Discussion Starter #1
Last couple of days I have noticed a slight knocking sound (maybe grating is more accurate) at the front when slowly maneuvering into my driveway.

Sounds like a mud guard loose , but I don't have any :lol:

Anyone have any ideas? all looks regular as far as I can see....
 

·
Registered
Joined
·
1,782 Posts
if you look under the car there are these plastic strips that are litteraly pinned on. its possible that one has slightly come off or even just rubbing on the drive.
 

·
Registered
Joined
·
2,890 Posts
Discussion Starter #5
Well its not trim....

It seems to be connected to the steering.

It is not suspension as bumps make no difference and its not momentum.

Do steering racks fail on these?
 

·
Registered
Joined
·
573 Posts
is it at full lock or close to?

i found mine makes creaking/clicking noises when reversing around a corner, especially if the car is wet
 

·
Registered
Joined
·
2,890 Posts
Discussion Starter #8
Suspension top mounts look at FIAT forums big issue on Grande Punto's symptoms sound the same
Got it in one mate :thumbs:

That's new clutch, flywheel, and both top mounts before I hit 6.5k miles.

Thank goodness for the warranty :lol:
 

·
Registered
Joined
·
559 Posts
Same scraping noise on wifes car at certain revs.
The wheels were off a couple of weeks ago to fit new front pads (honda garage fitted them), loose nuts had crossed my mind, or loose plastic underneath haven't had time for a proper look, will make the effort this eve..
 

·
Registered
Joined
·
52 Posts
Mito noise at front

Hi - ref noise at front of mito, I have noticed something too. My JTDM is 3 years old in May so warr. will expire. Going to book it in. The noise is strange, only really hear it when slightly turning wheel as I reverse or move off. Seems to be when a weight is shifting to one area or something. Difficult to describe. Also, I have noticed lately a slight whining noise when travelling at any kind of speed above 50. You can hear it above the engine noise, not dead loud but higher pitch. I'm on abot 50k miles now so thought it could be wear but going to mention that to garage too.
 

·
Registered
Joined
·
2,890 Posts
Discussion Starter #14
The steering noise sounds like mine, I only noticed it while parking in drive too. Get it in for a check now.

Not sure about the whining one...
 

·
Registered
Joined
·
52 Posts
Thanks for the message Bob. I rang the garage yesterday and they asked me to bring it today for a quick check/drive just to make sure no danger etc. Then booked it in for later in month. They mentioned that there has been a few issues with regards the top of struts becoming loose and could be that.:rolleyes:
 

·
Registered
Joined
·
573 Posts
i've noticed the whining noise - could it be the alternator? drivetrain?

the noise is very very faint, usually only heard when driving through an indoor car park, but nothing else seems up with the car at all so it doesn't worry me unduly
 

·
Registered
Joined
·
1 Posts
front strut

Same noise on my mito, been told that it is possibly the bearing gone on upper strut, will fone alfa tomorrow..
 

·
Registered
Joined
·
389 Posts
I hadnt seen this post by Bob before.

Mine has the same issue, dealers looked at it found the drop link was warn and they replaced it. They said they thought it was a bearing or strut.

Noise is still there though so im gonna get on to them about the top mounts as it sounds the same issue as on the Puntos.
 

·
Registered
Joined
·
52 Posts
Mito noise - grating at front, whining noise with engine

Hi

I posted a message about mine a few weeks ago and since then had it in for checking. They recognised the knocking noise (front) immediately, said it was the brace at top of suspension struts (probably not used the right words but you get my drift). There is a brace or something across the top, and it gets loose. Anyway, good news as they did it quicky and no fuss, not so good news in that seems to be a weakness perhaps of the spec? As for the whining noise, mechanic went for drive with me and he heard it, only faint and he seemed to think it was more prominent when in 4th gear. I think you hear it more when you slow down (seems a bit louder then to main engine noise). He didn't know what it was, they had it checked out - just by listening to it on ramp but couldn't locate the area or source. We agreed for me to bring it back a month later - see if it gets worse therefore easier to locate. Seemed a good idea rather than have them disturb everything etc. Warrentry runs out soon so will pursue. I think (wild guess) its something to do with gears (yes as a girl how would I know!) but the noise seems to be in tandem to the engine - but seperate. Like a drive or something. Difficult to explain. Will keep all posted.
 

·
Registered
Joined
·
59 Posts
Hi,

I have had this noise on my 2 year old 135 - only noticeable when going very slowly and turning the wheel, such as a when parking. Went to the dealer today. They said that the strut bearings had gone and it is a common fault on the MiTo. Anyway, it got fixed in the morning and the noise has thankfully disappeared.
 
1 - 20 of 21 Posts
Top