Alfa Romeo Forum banner

so where is my MAF?

727 10
So me being the curious type....where is my maf in the attached pictures. I've had a search and maybe I am just crap heh:lol:

I'm curious to see if anything improves by unplugging it.

Attachments

1 - 6 of 6 Posts

·
Registered
Joined
·
440 Posts
Discussion Starter · #9 · (Edited)
Hahaha I know! See attached screenshot ....I actually just reset the code using torque and Bluetooth odb reader I had.

That beep still puts the fear of god into me though. I've always thought my top end was poor for a car with 160bhp will experiment and see.

Did notice two bolts that connect to the air box...one is rusted to **** and the second is missing completely ?

When it beeped the fuel needle decided to die too ....silly Alfas! All sorted now..I feel like a hero

One things for sure I am never destined to become a mechanic !
 

Attachments

·
Registered
Joined
·
440 Posts
Discussion Starter · #11 · (Edited)
We all had to start some where just ask the question and keep learning :thumbs:
There will be people reading this that are to afraid of humility to ask so good on you
Cheers thanks for the vote of confidence! :thumbs:

Forums are for asking, if I can't ask on here where else am I supposed to ask! and I am sure I am not the only person that has had the question and I am sure I won't be the last!:D

I am going to take the car for a blast with it plugged in and with it not plugged in and see how it pulls at the top end
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top