Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
The rear windows on my 146 take ages to go down, & even longer to go back up. There are no noises coming from the winder motors & both sides take about the same amount of time. The windows are both perfectly located when fully up.
It's not the battery because I have just fitted a new one. The speed does not improve with the engine running.
These windows are rarely operated, as I tend to use only the front ones. Do you think that if I use them more often they will free up and operate faster?
 

·
Registered
Joined
·
1,503 Posts
While operating the window up and down, spray some silicon grease in the bottom corners so the glass going up and down works the grease into the runners. This should sort your problem :)

It specifically needs to be silicon grease, not just any old grease. Silicon grease can be got from Halfords and most motor factors and comes in a spray can like WD40.
 

·
Registered
Joined
·
46,602 Posts
While operating the window up and down, spray some silicon grease in the bottom corners so the glass going up and down works the grease into the runners. This should sort your problem :)

It specifically needs to be silicon grease, not just any old grease. Silicon grease can be got from Halfords and most motor factors and comes in a spray can like WD40.
What he said :)

I have to spray mine every now and then and silicon spray really works a treat :thumbs:
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
Thanks for the advice did what you said & all now ok.
 
1 - 6 of 6 Posts
Top