Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
I experience some squeaking/knocking from the front suspension when driving over a rough piece of road or uneven surfaces.
The sound seems to quiet down when driving at higher speeds.
I also hear it when driving around in "parking-lot" speeds while turning. Turning in general will also cause a slight knocking/squeak sound.

There is no vibrations or other faults, and driving in 30mph speeds+ and on the highway everything is quiet and calm.
When driving in lower speeds and quickly shift from left to right i can reproduce the knock sound.

I recently had both my upper wishbones changed due to a considerable squeak when driving over speed bumps. It quiet down a lot from that, but there is still some knock-squeak left. But then i can definitely rule out upper wishbone, if not bot the new ones were faulty.

Help is appreciated :)
 

·
Registered
Joined
·
250 Posts
Just had the same problem on my wifes 159 ti SW and having read a previous thread on here I found the problem to be a missing clip on the in wheel arch liner. As it was missing it was allowing the liner and the undertray to bang togther making a knocking noise similar to a hammer would if used on the floor pan.

It could still be drop links or even worse a broken spring but try the wheel arch liner as its the most simple and cheap possibility. According to the thread I mentioned it could be your problem as it was mine. Good luck
 

·
Registered
Joined
·
26 Posts
Probably wishbones need to be changed. has all 4 changed on my 159 and I experienced the same noise. The suspension is the weak part.
although could be just the bushes.
 

·
Registered
Joined
·
42 Posts
I'm having the exact same issue, went to get it checked out today at a local Alfa specialist and he said the upper wishbone arms are definitely gone and the lower ball joint may be gone too!
I'll get the uppers changed first then go from there
 

·
Registered
Joined
·
127 Posts
Discussion Starter #5
I'm having the exact same issue, went to get it checked out today at a local Alfa specialist and he said the upper wishbone arms are definitely gone and the lower ball joint may be gone too!
I'll get the uppers changed first then go from there
Any luck?


Sent fra min HTC Desire 816 via Tapatalk
 
1 - 5 of 5 Posts
Top