Alfa Romeo Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
30,126 Posts
Discussion Starter #1
Joining the M40 from the A46. Fourth gear up to 80, MCSF warning & beeping that only stops at idle or off throttle cruising:(

Sounds rough, lack power and is not pulling smoothly:eek:

Any ideas? Could be the last straw for it:cry:

Cheers,
 

·
Premium Member
Joined
·
19,119 Posts
Coilpacks mate. That would be my first guess.
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #3
Coilpacks mate. That would be my first guess.
Cheers matey. Anything I can check myself? Really don't want to limp back to Ned's:(
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #5
Could also be the ground to the heads, you've just had it rebuilt iirc Si?
Yep, rebuilt, rebuilt & rebuilt:lol:

Might call at the local dealers on the way home but already looking at TT roadsters & MX-5's on Clare's company car site:eek:

Cheers,

Simon
 

·
Registered
Joined
·
30,067 Posts
That'd be a shame :(

maybe the earth to the head has broken down (simple fix) causing grounding issues with the coilpacks as it would have been undone and disturbed when the engine was removed and it's getting on a bit now.

I'd love a 3.2 GT, my fav alfa post 2000
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #8
I know where to put the fluids but that's it:eek:

Can this be done without removing the covers etc? Sorry but don't even know what a coil back looks like:lol:

It's a great car. Clare's really attached to it (it's hers) but I just don't trust it anymore:(

There's also a slow speed knock / twang that's coming from the drivers side suspension of driveshaft (low speed manouvering or pilling off) since the new clutch, diff & flywheel got fitted.
 

·
Registered
Joined
·
2,161 Posts
Sounds similar to what I had a few weeks ago, although I didnt have constant beeping. I haven't had it rectified yet, but have had the codes read and it said possible MAF problem or coil pack 3 problem. It's going to involve having the Plenum off, so all pipes and leads off and coil packs swapped around to see if one is down. Coil packs are about £80, plus a decent bit of labour to have the plenum off. I know what you mean about losing confidence in the car, I thought mine was invincible.
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #11
A two minute fix thankfully. Loose connection to coil pack 4 :D
 

·
Registered
Joined
·
1,487 Posts
Good job, it was making me sad seeing someone was thinking about giving up on there GT. Now just need to find out that noise when pulling away slowly ( I have the same so be good to know what yours might be but mine seems to be coming from drivers side rear end ???? )
 

·
Premium Member
Joined
·
19,119 Posts
Cheers matey. Anything I can check myself? Really don't want to limp back to Ned's:(
The coil packs are under the covers so as you say you're not up for getting under the covers you'll have to take it back to ned. As Chris has also said the connectors can come loose. The heat kills them in the end though. If it is it's a reletively quick fix and you have the syptoms of misfore under load. Could also be a duff plug but they can be checked at the same time. Hope you get it sorted bud :thumbs:
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #15
The coil packs are under the covers so as you say you're not up for getting under the covers you'll have to take it back to ned. As Chris has also said the connectors can come loose. The heat kills them in the end though. If it is it's a reletively quick fix and you have the syptoms of misfore under load. Could also be a duff plug but they can be checked at the same time. Hope you get it sorted bud :thumbs:
You were right mate:thumbs: See post #11;)
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #18

·
Premium Member
Joined
·
19,119 Posts
Cheeky git. Glad its sorted though mate! :thumbs:
 
1 - 20 of 23 Posts
Top