Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello all

I am not a man who knows a great deal about cars, but I am learning fast

I have a GT in red on an 05 plate 1.9 JTD

On start at present in the glorious UK july heat, the car ticks over perfectly, then after 10 seconds the engine starts to shudder (hunting as per the mechanic) quite fast and a lot, which in terms causes a huge racket, and shakes the steering wheel. This last for anything up to 2 minutes if left idle.

The problem is resolved as soon as the accelerator is pushed down to 2000 revs, and thereafter the drive is fine and no other issues.

The mechanic says to me if it was my car, I wouldn't worry about it, but how can I get in the car, and let it shudder (hunt) whilst idle, there must be something wrong?

I ran rede through it with new diesel but no joy! My friends friend is a mechanic also, and he says it could could be the glow plugs, even though everyone says these diesel do not necessarily affect the cars performance, he says if running on bad plugs, the cylinders may not fire properly on idle?

Any thoughts, or anybody here of this before when car is started and sat idle?

Much appreciated
 

·
Registered
Joined
·
2,913 Posts
Either you are over-exaggerating it to a massive degree! and there really is nothing to worry about ......or more likely, there is a problem and I'd be taking it elsewhere to have it looked at. Find a reputable alfa indy near you (use the search function). Might be an easy fix but probably needs a scan of the ecu to find the problem.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks for the response much appreciated.
They actually plug it up to the management system and only found that there was an existing error regarding the clutch, which they removed but nothing else.
I would love to be over exaggerating the matter but I'm not, I love this car, but my love is slightly waining now that I have another possible issue to contend with?
Will ask Alfa I think, but it's going to cost me an arm and a leg im sure?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Hello, just to update, the problem was the egr valve!
Been replaced and all crud removed from the manifold, feels like a new car
 
1 - 4 of 4 Posts
Top