Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi I seem to get quite a lot of white steam from my 2ltr JTS until engine is almost up to it's 90 degree operating temp.. It's definitely steam with no smell or greasy deposits which disappears immediately it leaves the exhaust. I wasn't concerned when the weather was cold but now its a bit sunnier I'm still getting it.
I understand that the CAT's are quite a long way forward on a JTS engine leaving a long pipe for water vapor to collect but just a bit concerned as I don't see other cars showing the same symptoms in this current weather. There doesn't seem to be any coolant loss and no "sweet" smell from the vapor.
Hoping someone can put my mind at rest. Thanks
 

·
Registered
Joined
·
30,221 Posts
Water is a normal by-product of the combustion.
As long as you are not loosing coolant (or oil for that matter) I wouldn't worry.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Water is a normal by-product of the combustion.
As long as you are not loosing coolant (or oil for that matter) I wouldn't worry.
Thanks David Having recently acquired the car, (only 51,000 miles on an 05 plate) I guess i'm still at the paranoid stage where you listen out for every creak, groan and squeak. Anyway, now iv'e done all the stuff recommended on this site over the last month, i.e. cam belt, water pump, new thermostat, fan fuse, new 10-60 oil and filters and a new MOT, I can now start enjoying the car. Cheers
 
1 - 3 of 3 Posts
Top