Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1 (Edited)
selespeed help

I could not retrieve my previous posts / threads re selespeed failure. Anyway, the first to second gear was not smooth. Garage said the selespeed hose was leaking and the actuator was malfunction. I changed both, brand new from authorised dealer. after 16 months and 12,000km, now they say the actuator is going to die plus the selespeed pump plus the clutch pump release.

I am mad about the actuator. What is the point to go to fix the car in authorised dealer's garage and replace with genuine A.R parts!?

The problem of my car is : 1) sometimes when on steady, the engine will stall (when 1st gear is engaged it stall. it wont, or not yet happen, if you put on Neutral) 2) sometimes if you are with high rpm, it changes from 1st or 2nd or 3rd to N directly.

Anyone know what happen? thx
 

·
Registered
Joined
·
43 Posts
Discussion Starter #2
Will the pressure of the selespeed oil reservior affect the performance of the selespeed system? Or the reservior is not pressurised and it is just for keeping the oil that is not required at that moment.
 
N

·
Guest
Joined
·
0 Posts
good news buddy glad you got it sorted in the end would love to have a go in a gta selespeed i had a 2ltr 147 before i got my gta , and did enjoy driving it the only problem is, the problems selespeed courses :( but i did love it
The GTA selespeed is really, really good - much better than previous versions :) But this post is helpful - I wondered what would be the symptoms of the clutch going.... mine hasn't yet .....
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
sometimes when I was acclerating, say from 1st to 2nd or 2nd to 3rd ... , the gears jumped to N.
when I was going on very slow speed, say in front of traffic lights and prepared to stop, the engine will stall. Even when I was stopped and with foot on brake, engine stalled ...
clutch failure is a lot cheaper to fix than selespeed ... ha ha
 
1 - 7 of 7 Posts
Top