Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i was driving my 147 on a bypass road i put my foot down to change to 4 and i had a warning selespeed system failure and it would'nt change up a gear when i pulled in turn the engine off and back on still the same the only gears i had was 1,2,reverse i called out a recovery truck to take me home and its still the same after about 2 hours can any body help me out please iv only had my 147 9 weeks its y reg 147 selespeed 20lt
 

·
Registered
Joined
·
6,274 Posts
The usual checks first of all...

Is there selespeed fluid in the reservoir?

Can you hear the pump running?

Anything further than that will probably need AlfaDiag or Examiner to diagnose... My first guess would be the speed sensor though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
hi do you know what grade of oil i need i know its selespeed but the grade so i can get it from my local car shop thank, and thank for your reply
 

·
Registered
Joined
·
7,120 Posts
its comparable to auto transmission fluid (ATF) III, ATFII will not do, has got to be III, but the proper stuff is better still

HTH
 
R

·
Guest
Joined
·
0 Posts
Recommended Selespeed fluid is Tutella CS, i ordered my last bottle from my local Fiat dealer and picked up the next day for just under £13 :thumbs: there are other compatible fluids but AFAIK i don't think mixing them is the best idea :thumbs:
 

·
Registered
Joined
·
7,120 Posts
atf III is the comparable spec, so should be OK. I have used in in my car all year with no adverse effects. You're right that I would have prefered the CS stuff, but on reflection the ATF III is more widely available and therefore less likely to be stuck in the future.
 
1 - 7 of 7 Posts
Top