Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi There, changed my 159 for a brera, bought at auction and car had a host of problems, basically just abused by previous owner. Around 2k spent getting it back to road worthy condition & just smaller problems now. Next on the list is get seatbelts to recoil, currently just lying there with little or no tension. Anybody have or had this problem ? Is it the pre tensioners i need to change, already checked for twist etc but all seems ok with the belts.

Any help or advice would be much appreciated.
 

·
Registered
Joined
·
439 Posts
Had this on my Brera. I know you say you've checked for twists.. thought I had too, but the twist was literally right at the end of the belt. I thought I had pulled the belt all the way out but apparently I hadn't. Same thing happened every few weeks and always had to pull belt a long way out to remove twist. Also had trouble with belt getting wet- eventually traced to faulty seal in rear driver's side window.
 

·
Registered
Joined
·
561 Posts
I've had it a couple of times when a passenger let it recoil whilst twisted. Had to take the plastic interior side trim off to get to the twist right at the end.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Thanks guys, took both side panels off & the belts were twisted right at the bottom. Untwisted them and both now recoiling fine. But fixing this problem has now lead to my next problem, now they recoil the passenger belt is coming back WET...obviously water is getting into the area that houses the pretensioners so probably faulty window seal...!!!!! God i love driving this car but this is never ending......:(
 
1 - 5 of 5 Posts
Top