Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
hi guys

trying to install an aftermarket 2din to my friends 159, that comes with that infamous quadlock connector. does anyone have the wiring schematic of the quadlock? unlike the non nav systems, this oem satNav doesnt come with the wiring sticker on the top.

im thinking in buying the quadlock adaptor from ebay.it, but it only converts the speaker wires, black, yellow, and gives the red to connect the positive of the lighter.

my idea is to buy that adaptor and also the normal cstar2 and connect one to the other, but i will still be mussing the extra wires from the quadlock.

if i can get the quadlock schematic, i can also cut all the wires and make convert it to the standard alfa iso plug.

any toughts?

thanks

https://www.ebay.it/itm/Cavo-adattatore-ISO-autoradio-Alfa-Romeo-Giulietta-2010-08-2013-navy-di-serie/251296227140?hash=item3a826c1f44:g:9q8AAOxyk99RzXN6

https://www.ebay.co.uk/itm/Alfa-Romeo-159-Brera-Steering-Wheel-Stalk-Control-Adaptor-CTSAR002-2/162502007012?hash=item25d5dfd8e4:g:oloAAOSwrhBZChLP
 

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,713 Posts
Like jwq (in other thread), I haven't seen a schematic. However, if yours is like the attached photo, I don't think it should be any different to common Alfa wiring. Worth using a multimeter to confirm the 'constant' +12V (permanent battery) and 'switched' +12V (ignition).

Disclaimer: I obviously can't hold responsibility for any errors!

It appears that:

#10: probably 'switched' +12V (ignition)
#12: 'constant' +12V (thick yellow wire)
#13: CAN B
#14: CAN A
#16: GND (thick black wire)

#1-8 would be standard speaker wiring.

That would seem most logical.

:)
 

Attachments

·
Premium Member
Joined
·
7,004 Posts
looking at the picture of the quadlock, you can probably come a long way looking at the wire colour codes in elearn. They seem to correspond. See f.i. (standard radio, no nav, no bose)


A Light Blue
B White
C Orange
G Yellow
H Grey
L Blue
M Brown
N Black
R Red
S Pink
V Green
Z Violet
 

Attachments

·
Registered
Joined
·
70 Posts
Discussion Starter #4
Thanks for the replies. Im gonna go into cutting the wires from the quadlock and make ISO plugs, to plugin in the connects adaptor. Ill let you know the result
 

·
Premium Member
Joined
·
7,004 Posts
Thanks for the replies. Im gonna go into cutting the wires from the quadlock and make ISO plugs, to plugin in the connects adaptor. Ill let you know the result
Stout fellow ;)
Shouldn't be a major undertaking, let us know how you get on :)
 

·
Registered
Joined
·
30 Posts
Thanks for the replies. Im gonna go into cutting the wires from the quadlock and make ISO plugs, to plugin in the connects adaptor. Ill let you know the result
Hi,

Did you get it to work? Do you have any pictures? I'm about to do the same right now, but I can't seem to get it?
 

·
Registered
Joined
·
1 Posts
Hi,

Did you get it to work? Do you have any pictures? I'm about to do the same right now, but I can't seem to get it?
Hi. Any updates on the topic?
I'm ordering Quadlock to ISO harness from Aliexpress and Connects2 CAN-BUS adapter to fit Chinese Android HU.

Connects2 support said:

"Unfortunately we do not have a steering control interface that will be compatible with an Alfa Romeo 159 with an OEM (orignal) navigation. Our interfaces for the Alfa Romeo are only for the Basic radio / CD player."
 

·
Registered
Joined
·
30 Posts
Hi. Any updates on the topic?
I'm ordering Quadlock to ISO harness from Aliexpress and Connects2 CAN-BUS adapter to fit Chinese Android HU.

Connects2 support said:

"Unfortunately we do not have a steering control interface that will be compatible with an Alfa Romeo 159 with an OEM (orignal) navigation. Our interfaces for the Alfa Romeo are only for the Basic radio / CD player."
I got it to work with the CTSAR002.2 and this https://carsound.dk/produkt.asp?id=12708&pk=&webid=&soeg=70105

You ONLY need to use the two ISO-connectors - the other connectors are not used at all.

I will have to pull everything apart one of these days as I have to fit my DAB-antenna. If you'd like, I can take pictures...

- Anders
 

·
Registered
Joined
·
2 Posts

·
Registered
Joined
·
5 Posts
have you just pluged in the iso connectors or it was also requiring to modify them?
I have the same question...

I have installed a Chinese HU (Xtrons TE706PL). If I connect the HU directly to the car everything work fine but if I connect the HU throught Connect2 interface the HU reboot and doesn't start I think the HU go to protection mode....
 

·
Registered
Joined
·
2 Posts
I have the same question...

I have installed a Chinese HU (Xtrons TE706PL). If I connect the HU directly to the car everything work fine but if I connect the HU throught Connect2 interface the HU reboot and doesn't start I think the HU go to protection mode....
HI, Ive been trying to make connects 2 work but unfortunately i failed. In my case when plunged the new unit via quad lock adapter the radio drain the battery. Ive managed to contact incartec and they can make it work with an item called 39-FIA-02 that cost £59. i ordered one today by phone as the item aint on their page. Once its arrive ill work on it and will put some update.should be in next few days. fter the conversation with incartec i found out they came across this problems before and they only made the item as they have worked on one of 159 with quadlock connector. h
 

·
Registered
Joined
·
1 Posts
Hello . Are You able to make it work . I have connects 2 harness and quadlock to iso adaptor i have rewired connection but unfortunatly steeing wheel buttons dosnt work .did aomw havw a photo how he connects this?
 

·
Registered
Joined
·
20 Posts
As long as you dont have bose or blue & me you shouldnt have a problem. You dont need any can interface. It works directly. Atleast it did for my mito 2010
 
1 - 15 of 15 Posts
Top