Alfa Romeo Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
176 Posts
Discussion Starter #1
So i just washed my car for the first time since i picked it up and while rubbing hard to get the stubborn bits off i noticed a couple nasty orange looking specs. It is definitely rust. i started to look harder for more and the whole side is covered with these specs. both sides.. then i noticed under the boot lid. the part that gets dirty culminating but isn't ever seen unless the boots open, and thats got all the specs too! I don't think theres anything i can do about it now is there ? through the dealer or anything ? :cry:
 

·
Registered
Joined
·
44,882 Posts
I presume it's still under warranty, take it back to the dealer and complain like you never complained before.... RUST!!!! on a car less than 2 years old in the 21st century.... I'm speechless :rant:
 

·
Registered
Joined
·
176 Posts
Discussion Starter #4
I know! I called my brother and showed him and he said it wasn't rust so i rubbed at it, and it wouldn't move or fade and he checked and agreed that it was rust, he's good at haggling and knows good things to say he has a lot of sense and knowledge so i might take him with me to the dealer.
 

·
Registered
Joined
·
176 Posts
Discussion Starter #5
alfapud, I don't wanna think it's rust but that's the only thing i can come up with, it's the colour of rust and has that horrible little fade round it where it looks like it's been running
 

·
Registered
Joined
·
6,715 Posts
alfapud, I don't wanna think it's rust but that's the only thing i can come up with, it's the colour of rust and has that horrible little fade round it where it looks like it's been running
take it to the dealer no questions asked, even if your unsure. go, now. get in your car, drive there get out the car and just point at what your annoyed with. dont say anything just point. if it is rust they should sort it out, sharpish. looks like the mito is the new sud :lol:
 

·
Registered
Joined
·
6,715 Posts
If there was a problem someone on here would have bought it up by now, so yes :p
exactly, if there was a problem on here you dont take into account all the mito owners that do not use this forum and i believe that a majority of these owners are not regisered. you are only using one source of information. i would advise you to check alfabb, the news and then do a survey to all mito owners to see if they have encountered rust. then were level. :p
 

·
Registered
Joined
·
44,882 Posts
exactly, if there was a problem on here you dont take into account all the mito owners that do not use this forum and i believe that a majority of these owners are not regisered. you are only using one source of information. i would advise you to check alfabb, the news and then do a survey to all mito owners to see if they have encountered rust. then were level. :p

If there was a problem, which I don't think there is, it would have been all over the motoring press. There would have been headlines saying Alfas are still rusty old heaps, it would be an issue whether you drive a Mito with rusty bits or not.
 

·
Registered
Joined
·
39 Posts
alfapud, I don't wanna think it's rust but that's the only thing i can come up with, it's the colour of rust and has that horrible little fade round it where it looks like it's been running
Mr. MooMoos says it might be what they term industrial fallout - often worse if car has been on train transport or parked near a railway. It is generally small particles of metal mainly from brake linings, etc that bed into the paint. If it was like it when it was delivered then it is poor prep by Alfa or their Dealer - they used to use an oxalic acid wash to soften and remove it but not sure if that is still used now. If it has developed since you have had the car then it can be removed with auto clay - Bilt Hamber soft is good. The detailing posts on here may be of help. Hope you get it sorted out ok.
 

·
Registered
Joined
·
176 Posts
Discussion Starter #13
haha mate. I was a bit hasty to post on here my problem. when you said to take it to the dealers i went outside for one last check before deciding to go or not. I scratched at it and it came off.. i dunno what it was but it comes off. maybe theres no rust problem after all, i might of just been jumping to worst case scenario after already worrying something might be wrong for letting it get so dirty :) SORRY GUYS!
 

·
Registered
Joined
·
44,882 Posts
haha mate. I was a bit hasty to post on here my problem. when you said to take it to the dealers i went outside for one last check before deciding to go or not. I scratched at it and it came off.. i dunno what it was but it comes off. maybe theres no rust problem after all, i might of just been jumping to worst case scenario after already worrying something might be wrong for letting it get so dirty :) SORRY GUYS!
:mad:

:tut:

:rant:

:cool:

:cheese::cheese::cheese:

You silly person :cheese:
 
N

·
Guest
Joined
·
0 Posts
Surface contamination from an angle grinder or such like?

Probably as well to clay it asap.
 

·
Registered
Joined
·
2,136 Posts
maybe the rust was caused by a product you used? what type of scrubber did u use? and did you use any cleaning detergents or something?
 

·
Registered
Joined
·
2,375 Posts
This has definitely been discussed on this forum before.
I seem to recall someone with a metallic black Mito mentioning "orange specks".
Have you tried doing a search for such a thread?
 
N

·
Guest
Joined
·
0 Posts
This has definitely been discussed on this forum before.
I seem to recall someone with a metallic black Mito mentioning "orange specks".
Have you tried doing a search for such a thread?
I thin that's red flake and it's part of the paint job, no? :confused:
 
1 - 20 of 23 Posts
Top