Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2011 Giulietta 1.4 multiair with 156000kms that started giving me problems about a week ago.

It started off as a small misfire so I changed the spark plugs and put some fuel injector cleaner into the tank thinking that it should be 1 of the 2 that is giving me problems. The car ran well for about 20kms, then I noticed a cloud of white smoke coming from the exhaust.

Thought it might just be the injector cleaner that was burning off so I kept driving. A few minutes later, the engine light came on and I had a massive loss in power. Car started to sound different as well. Luckily I was only about 2kms from home.

Anyone encounter the same or similar problems?

Any sort of help and advice is appreciated.
 

·
Registered
Joined
·
446 Posts
most likely the multiair unit considering you have a 2011 car. Sometimes the unit can be repaired, most often you need a new one.
 

·
Registered
Joined
·
5,086 Posts
White smoke from the exhaust is usually coolant getting into the engine. What are the fault codes?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
most likely the multiair unit considering you have a 2011 car. Sometimes the unit can be repaired, most often you need a new one.
Will definitely check it out. Haven't had a chance to get my G to the mechanic. Wouldn't there be an unusually loud tappet sound coming from the engine bay if it was the multiair unit?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
White smoke from the exhaust is usually coolant getting into the engine. What are the fault codes?
Thought that as well, however the coolant level is normal. Haven't taken it for a diagnostic test yet.

I'm a bit hesitant to drive the car at all because of the drastic loss of power. Also don't want something else to happen to it.
 

·
Registered
Joined
·
38,287 Posts
Sounds like fuel is going straight into the exhaust to me. Either a seriously overfuelling injector or not enough air getting into the cylinder for it to be burned. The later being caused by non opening inlet vales...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Took her to my mechanic. He says that the catalytic converter is blocked. Caused by over fueling.

Hopefully it isn't something major.

Thanks for the help everyone.

Will post updates.
 

·
Registered
Giulietta 1.4tb Lusso 170 (OU61)
Joined
·
25 Posts
Took her to my mechanic. He says that the catalytic converter is blocked. Caused by over fueling.

Hopefully it isn't something major.

Thanks for the help everyone.

Will post updates.
Hope this gets sorted for you Jude!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Cleared the catalytic converter. Was badly clogged.

The smoke cleared, but the misfire is very bad, car has almost no power and stutters. Almost impossible to keep it in any other gear besides first.

They suspect that fuel injectors 3 and 4 aren't working properly.

Any advice on what I should check or do before removing the injectors?
 

·
Registered
Joined
·
446 Posts
they are sure the misfires are on cylinders 3 and 4? swap the coils over from 1 and 2, then do the same with the spark plugs to rule out it's an ignition issue. After that swap injectors from good cilinders to bad as i still think it's a multi air issue.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #12
Had all 4 fuel injectors cleaned out and the PCV valve replaced.

Everything seems to be working fine. Hope it stay this way.

Thanks for all the help. Highly appreciated.
 
1 - 12 of 12 Posts
Top