Alfa Romeo Forum banner

1 - 12 of 12 Posts
F

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I've posted about this before, but I get a horrible smell off rotten eggs when I start the car, especially when warm. It's a 2007 2.4 with 26k on the clock. I've had it a couple of months now.

It isn't just a slight whiff, it stinks at times.

I think there is probably something wrong with the cat - I'll ask the dealer to have a look at it because it's booked in tomorrow to have its auto gearbox fixed.

Anyone else experienced this?
 

·
Registered
Joined
·
1,471 Posts
Try running and starting it with the aircon off, to rule that out. Bacteria can build up in the aircon system and cause really bad smells in the car.
 

·
Registered
Joined
·
937 Posts
If it is coming from the exhaust have you tried different fuel? An egg smell usually means there is too much sulphur. It could be the DPF needs to re gen or the cat is not getting hot enough. Are you doing mostly short journeys?
 

·
Registered
Joined
·
86 Posts
Yes, it happened on my 1.9 recently and I've put it down to fuel;
I try to fill up at the local Shell as it's always about 2-3p per litre than surrounding garages, including other Shells nearby.
About 3 months ago after filling the tank I started to get the same sulpherous smell which lasted about halfway into the next tankfull.
The strangest thing was that I seemed to get about 3mpg more out of the "smelly" tankful than usual.
The smell and the extra mpg have now long gone.
 
1 - 12 of 12 Posts
Top