Alfa Romeo Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
Hi everyone
Took my car to RC Performance Centre in Bury,Manchester this morning and during the run a few faults came up on the info centre. First was an ABS fault then VDC then finally MCSF accompanied by the engine management light.

The guy said that his Dyno plot manchine wasnt working so wrote down some performance figures for my which were as follows:
87 [email protected] in 6th
[email protected] in 5th
[email protected] in 4th

final power was [email protected]

He said all figures were calculated at the wheels.

When he finished he plugged in his diagnostics machine and tried to clear the fault codes off but one wouldnt go away (P0100 mass air flow) He said this happened when he was at max RPM.

I regret taking the car there now because it was perfectly fine before and now it sounds like its gonna cost me!!

Anybody ever had anything similar before?

Cheers
 

·
Registered
Joined
·
3,480 Posts
ABS and VDC faults are common appearance when a car is used on rollers,because only the driven wheels are rotating(unless its a 4wheel dyno).
As for your air mass meter fault if it threw an error it would happen on the road sooner or later.:)
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
Hopefully it's just the maf and nothing more.has anyone changed one themselves before?is it an easy job?
 

·
Registered
Joined
·
310 Posts
The masurement seem off as well, 220 WHP is realy off, as far as i know stock cars show somewhere between 190 and 210.
 

·
AO Car Of The Year Winner 2015
Joined
·
3,202 Posts
Why did he give you data in different gears? Cars are usually measured in one gear, usually the one that has closest ratio to 1:1, so 5th on a GTA.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #8
I don't really know why he gave me the info in different gears,his computer hard drive wasnt working so gave me the info on paper.he had altered the final power in ink so hard to make out wether it was 220 or 202.looking at it it's probably 202,the cars stock so does that seem about right?
 

·
Registered
Joined
·
115 Posts
Discussion Starter #10
Bought some Isopropyl alcohol spray from maplins and cleaned the sensor this morning and it just made it worse, the car started to almost kangaroo down the road where as it didnt before.Looks like im going to have to buy a new one, worth a try for a tenner tho!
 

·
Registered
Joined
·
436 Posts
So am I right in saying instead of buying a new maf I can just replace the sensor for half the price? Mines not gone yet but just when it does I know what to get
 

·
Registered
Joined
·
115 Posts
Discussion Starter #16
well yeah ive ordered one which arrived today so will fit it tomorrow and see what happens. Does anybody know if the engine light will go out after or will i have to do an ecu reset to clear the fault?
 

·
Registered
Joined
·
115 Posts
Discussion Starter #19
I had to clear the fault. Just used the torque app on the android phone.:thumbs:
So is yours all ok again now then?mines going in tonight.ive got an iPhone so prob not got that app so will have to follow one of the guides on here
 

·
Registered
Joined
·
2,050 Posts
So is yours all ok again now then?mines going in tonight.ive got an iPhone so prob not got that app so will have to follow one of the guides on here
yeah mine is fine now. I changed the maf for a new one. couldn't wait. when I get time I will clean the nearly new one and refit to see if i have jumped the gun but if i have at least i will have a spare one.
 
1 - 20 of 33 Posts
Top