Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
People! As the yellow engine light came on yesterday and wont turn off, with the message - "motor controller failiure" I started wondering...

On the 147 1.6TS (120HP), does the rev limit, cut in like in most cars? Like a machine gun?

Mine, on 1st gear, gets to 6500 and it feels like a strong wind has start blowing against the car - it stops accelerating. I was expecting a "ta ta ta ta ta..." like most cars do!

Reading about the MAF, I started wondering if it was a symptom... :-(

Everything else in the car feels ok! I guess(?) Never driven other ALFA...
 

·
Registered
Joined
·
9,179 Posts
Rev limiter on 2.0 TS is set to around 7200!! Probably around same on 1.6.

Try disconnecting the MAF (it's mounted in the air intake pipe to right of engine cover) and try again. If it revs more freely you have a failing MAF. And engine light will come on if MAF is dead or failing (it comes on when you disconnect it and should go out when reconnected).
 

·
Registered
Joined
·
226 Posts
Discussion Starter #4
Hi,

What you're describing sounds right.

To read/clear the fault light you'll need to hook it up to diagnostics equipment...

Cheers,

Iain
Sorry! By "sounds right" You mean, "it's broken" or "It's ok! The rev limiter just decelerates the car and IT does NOT sound like a machine gun" ?
 

·
Registered
Joined
·
9,179 Posts
It doesn't sound like a machine gun .. more like bad misfiring ...
 
1 - 5 of 5 Posts
Top