Alfa Romeo Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
8 Posts
How are you finding the TRW units? I've bought a full set for mine but haven't fitted them yet. Also, when you dismantled the struts, what were the insulating rings/top plates/top mounting rubbers like i.e. were they reusable?
 

·
Registered
Joined
·
554 Posts
Discussion Starter #22
How are you finding the TRW units? I've bought a full set for mine but haven't fitted them yet. Also, when you dismantled the struts, what were the insulating rings/top plates/top mounting rubbers like i.e. were they reusable?
So far, so good with the TRW units - comfortable and compliant, which is what I wanted.

The top mount rubber bushes were in pretty good condition, but I had bought new ones so I replaced them anyway. The original ones would have been fine to refit. The bump stop rubbers had been destroyed, so I replaced those too, as well as the cylindrical dust shields.
 

·
Registered
Joined
·
254 Posts
It's been a while, but - yes, it was the n/s damper causing my suspension "thump" over potholes.

The device had to all intents and purposes failed and was unable to prevent the suspension bottoming out as the car went into potholes (of which there are many in my neighbourhood).

Yesterday I fitted new OEM spec TRW dampers - job done, and no more bottoming out.

The old dampers looked like they were the originals - so after 129k I guess they were a bit tired...
I would bet that 95% of the 166 s have bad shocks, and I am sure also that they dont last long because of te design of the suspension. they are like timing belts, replace at 30000miles. the hard springs hide bad dampers!!!!
 
21 - 23 of 23 Posts
Top