Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
My flexi has a hole in it so is blowing like mad and causing the motor control system light to come on and say the lambda sensors are failing (changed these a few months ago) and also make the engine noisy as hell.

I managed to source a front cat for my 147 from a breakers instead of paying the £££'s I was quoted by the garage, also I have decided to fit it myself as it looks quite straight forward, but thought I'd ask you guys first!

So any tips? Should I do it after going for a drive, once its cooled enough to touch?

I have the metal gaskets and also some exhaust assembly paste, all the right tools and will be doing it up on some ramps with the father-in-law.

Is it as straight forward as it looks?

Cheers :)
 
G

·
Guest
Joined
·
0 Posts
It may look easy, but never is:lol:

I tend to have new spare securing nuts/studs/ bolts just in case as there is always one stubborn bugger that won't give... and when it does, snaps!:rolleyes:

If you have a blow torch, it is a lot, lot easier

Concentrate the heat on the securing nuts until they glow red hot, now spray wd40 on them (you will get a lot of steam/smoke).
You will notice that the nuts will go back to normal colour, but be warned they will be stinking hot still.
Get a socket or decent spanner on them and tighten them a just a tiny bit (cracking on) now give loosening a try ..... If it still won't budge, repeat the process all again.
Lambda's require a special 22mm cut away socket or a long, good quality deep dished goose head ring spanner (to clear the wires and multiplug). Same heating principle if it won't budge.

Important: when re-assembling , DO NOT use exhaust sealing/ jointing paste on pre-cat or pre- lamda sensor joints (before the cat). It is safe to use on the other sections of exhaust after the CAT but the chemicals in the paste can react badly with the precious metals inside the CAT & are the quickest way to kill your new CAT or bung up the HG holes in the lambda sensors!
Not good!


Good luck mate:thumbs:
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
It may look easy, but never is:lol:

I tend to have new spare securing nuts/studs/ bolts just in case as there is always one stubborn bugger that won't give... and when it does, snaps!:rolleyes:

If you have a blow torch, it is a lot, lot easier

Concentrate the heat on the securing nuts until they glow red hot, now spray wd40 on them (you will get a lot of steam/smoke).
You will notice that the nuts will go back to normal colour, but be warned they will be stinking hot still.
Get a socket or decent spanner on them and tighten them a just a tiny bit (cracking on) now give loosening a try ..... If it still won't budge, repeat the process all again.
Lambda's require a special 22mm cut away socket or a long, good quality deep dished goose head ring spanner (to clear the wires and multiplug). Same heating principle if it won't budge.

Important: when re-assembling , DO NOT use exhaust sealing/ jointing paste on pre-cat or pre- lamda sensor joints (before the cat). It is safe to use on the other sections of exhaust after the CAT but the chemicals in the paste can react badly with the precious metals inside the CAT & are the quickest way to kill your new CAT or bung up the HG holes in the lambda sensors!
Not good!


Good luck mate:thumbs:
Unfortunately I had already started this before your reply, because of some of the bolts been rounded I ended up taking it into a garage to finish off.

They managed to get it off and on again but they used a sealant (I didn't see what one but it was in a mastic gun) when connecting it up to the manifold and also to the 1st cat.

It runs brilliantly now but I'm guessing from what your saying I'm going to have some problems in the near future with it? maybe I'll bevlucky and get away with it? Or is that wishful thinking?!?!

Cheers
 
1 - 3 of 3 Posts
Top