Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
421 Posts
Discussion Starter #1
Anybody tried this successfully without damaging the "chrome" surrounds.
I pinched out the 2 pins and tried prising out with a small electrical screwdriver but the chrome marked so now need another surround. I ended up drilling holes on the rear plastic backing and pouring in some meths to soften up the glue. After leaving the meths in there for around an hour it eventually came off with the persuasion of a driver pushing from the rear.

Is there another better method or a better solvent for the glue perhaps?

Cheers
 
0

·
Guest
Joined
·
0 Posts
I removed entire grille & soaked in hot water in the sink (mrs Jon was out at the time :lol: ) but also poked it off through a hole I made from behind :)

(does that sound rude? :lol:)
 

·
Registered
Joined
·
421 Posts
Discussion Starter #4
Thanks Jon,

I guess the simplest is the best. Didn't think of hot water, but there must be a solvent that just disolves the glue..... Anyone?

Anyway, when the "new" unit arrives I'll try that and no more drivers.

Cheers
 

·
Banned
Joined
·
81 Posts
I,ve done lots of them, need 3 metal drill bits from small to around half inch, drill pilot hole in centre of badge ( no going back from this point ) making sure you only go through the thin badge, after 3 times hole is large enough to use a screwdriver to work badge from the centre without damageing the surround, if the glue is tough it takes a bit of patience, don,t try to force it just keep gently priseing it from different angles, normaly takes me about 5 minutes. ps not for 147,s they have a bolt.
 

·
Registered
Joined
·
237 Posts
yeah. drill three holes in the back of mine, and used the birds hair dryer. after about 10 minutes it came off with some screwdriver persuasion. You need to heat the badge up until the glue gets tacky.
 

·
Registered
Joined
·
7,032 Posts
I heated the damn thing with a butane flame came off without protest !
 

·
Registered
Joined
·
2,133 Posts
Heated with a heat gun for a while and it popped off, did use a screwdriver with some cloth protecting the edge but doesnt take much effort once you have heated it plenty
 

·
Registered
Joined
·
170 Posts
im about to gibe mine a go, but keep putting it off, i was going to douse it in lighter fluid, amazing stuff at breaking down glue!! better not try getting mine too hot for a while after that or it could all go very wrong haha
 

·
Registered
Joined
·
98 Posts
The nut on mine is tuck to the bolt, so I cannot undo it (the nut and bolt just turn together). Have tried soaking in DW40, no help thus far.

Any tips, or do I just get a new chrome surround from somewhere (and if so, where?)
 
1 - 12 of 12 Posts
Top